What are the requirements for using the XG-7000 Series?
The hardware for executing inspection (controllers and cameras) and the software for creating programs (XG-H7N) are required.
What types of controllers are available?
There are five types: standard type that connects to Keyence digital cameras, high-speed type that supports 2-megapixel cameras, high-speed, high-capacity type that supports 5-megapixel cameras, standard type that connects to analog cameras, and high-speed type that connects to analog cameras.
What are the differences between the XG7000, XG7500, and XG7700?
The cameras that can be connected and the image processing speeds are different.
Can all controllers be connected to four cameras?
By attaching a camera expansion unit, each controller can be connected to four cameras and perform simultaneous capture for the four cameras.
What is supplied with the controller?
The controller comes with an installed SD card (SD1), instruction manual (A4 size, 8 pages), and a set of replacement terminal block labels.
Is a console required to use a controller?
All settings required for inspection can be configured with a computer, so a console is not required.
To perform setting operations on the controller, provide an optional console.
Can the controller firmware be upgraded without the use of a console?
A separate console is required for firmware updates because virtual console input cannot be performed with the remote desktop.
Can a commercially-available SD card be used?
This system does not guarantee the use of SD cards other than those provided with the controller.
What types of digital cameras are available?
There are 16 types: 31-megapixel, 200-megapixel, 7× speed 31-megapixel, 7× speed 100-megapixel, 7× speed 200-megapixel, 11× speed 500-megapixel, and compact cameras, all available in color and black-and-white.
Which analog camera models have operations guaranteed with this system?
This system supports analog cameras manufactured by Keyence, Sony, and Toshiba Teli. See the specifications for supported models.
I want to connect an analog camera. How should I set the DIP switches?
For CA-CM20, use the factory settings. See "Installing the Camera" in chapter 2 of the user manual for details.
Can a camera with a conventional image sensor be used?
Among digital cameras for the XG-7000 Series, only dedicated cameras whose model name starts with XG can be used. (CV-5000 Series cameras can be used only a camera cable.)Among analog cameras, the CA-CM20 of the XV-1000 vision system can be used including camera cables.
Can analog and digital cameras be used together?
Among analog cameras, this system only supports dedicated models (ending in A), so they cannot be used together with digital cameras.
Does this system support ultraviolet or infrared cameras?
This system supports the Sony XC-EI50 and XC-EI30 infrared cameras (with different CCD sizes) and the Sony XC-EU50 ultraviolet camera.
Can analog camera images be inverted horizontally?
What types of manuals are available?
There are four types of manuals.
Each manual is provided in the XG-H7N software in PDF format.
(1) XG-7000 User Manual: hardware manual
(2) XG VisionEditor Reference Manual (Programming edition): Describes how to create flowcharts and user interfaces.
(3) XG VisionEditor Reference Manual (Control edition): Describes how to control I/O and serial communications.
(4) XG VisionTerminal User Manual: Describes remote operation and logging.
How do I view the manuals?
After installing the XG VisionEditor and the XG VisionTerminal, click the Start menu or select [Help] from the application menu to open the desired manual in PDF format.
I cannot open the XG-7000 User Manual (hardware manual) from the Help menu in the VisionEditor. Do I have to purchase this manual separately?
This manual is installed to your computer when you install the VisionEditor, but it cannot be opened directly from the Help menu. The XG-7000 Series User Manual can be opened by navigating to the default installation location (C:Documents and SettingsAll UsersStart MenuProgramsKEYENCE ApplicationsV-Works for XG).
What kind of user support is available for creating flowcharts?
You can download sample files and the latest software from the XG User Support page. XG technical support representatives are also available at Keyence offices to answer your questions.
What types of software are available for use with this system?
There are two types: Integrated Vision Editing Software "XG VisionEditor" and Remote Control Software "XG VisionTerminal".
What is the purpose of the Integrated Vision Editing Software "XG VisionEditor"?
This integrated vision editing software comes with a series of setting functions that enable construction of image processing flows and user interfaces on a computer as well as debugging, simulation, and uploading.
What is the purpose of the Remote Control Software "XG VisionTerminal"?
This software enables monitoring and operation of the XG-7000 controller from a computer via Ethernet or USB connection. It also has functions for monitoring multiple controllers connected to a network and functions for logging measurement values and image data.
What are the system requirements for running the Integrated Vision Editing Software "XG VisionEditor"?
Processor: Core 2 Duo 1.06 GHz equivalent or faster (Core 2 Duo 1.80 GHz equivalent or faster recommended)
RAM: 1 GB or more (2 GB or more recommended)
Available hard disk space: 600 MB or more at installation, 500 MB or more at operation
Can a purchased copy of the XG-H7N software be used on multiple computers?
To operate the XG VisionEditor, each computer must have a separate activation code.
Apply for an activation code using the XG User Support page. Basically, one activation code is issued per XG-H7N copy. To use the software on multiple computers, please purchase multiple copies of the software.
What is the workspace used in the XG VisionEditor?
This is a folder representing the virtual XG controller set up on the hard disk of the computer. Within the workspace folder is the SD1 and SD2 folders, which are equivalent to SD card drives for the system, and each of these folders can store program data and registered image data.
The workspace can be switched to enable management of multiple controller settings from a single computer.
How many programs can be created on one controller?
By using the two SD card drives, you can create program data for up to 2,000 programs. Each SD card can store up to 1,000 programs (No. 000 to 999), but depending on the settings, the SD card may become full before reaching 1,000 programs.
How many days do I have left on my trial period of the XG VisionEditor?
You can view the date the license was activated.
Select [About...] in the Help menu to display the [Extension Activation Code Input] window. This window displays information about the trial period in the format "The trial period is 30 days starting (year/month/day)."
The computer operating the XG-H7N software failed and I need an activation code for the new computer. What should I do?
Contact your local KEYENCE office.
How many units can be set on a flowchart?
Up to 1,000 total units or 997 measurement units not including the minimum required units can be set. (The actual number of units that can be set depends on the memory capacity of the system.)
Can a flowchart that is long and cannot be entirely displayed in the Flowchart View be displayed in a list?
Change the size of the display by changing the zoom ratio of the Flowchart View in Window on the menu bar.
How do I transfer a program created on a computer to a controller?
There are two ways to transfer a program file created with the XG VisionEditor: upload the program file while connected to the controller by USB or Ethernet, or write the data to an SD card as a file and have it read by the controller.
Does the writing of data from a computer to the XG-7000 system create any processing delays?
When data is uploaded and overwritten to a currently used program, the data is reset. The operations are not affected for those programs not currently being used.
What generation is the capture file setting?
One "generation" is from the start unit to the end unit. The "first" and "second" image file settings are one "generation" each.
Can changes be made to Layout 1 to 5 of the XG VisionEditor?
The views and windows in the XG VisionEditor can be positioned as desired. Layout 1 is positioned at the optimal location for creating an image processing flowchart, and Layout 2 is positioned at the optimal location for creating a user interface. Layout 3 to 5 have the same positions and can be repositioned as needed.
How do I reset the layout positions in the XG VisionEditor?
Select [Reset Layout] in the Window on the menu bar.
What is the yellow square at the bottom left of a unit in the Flowchart View?
This indicates that a comment has been entered in the [System Settings] tab of that unit. Placing the mouse over the unit with a yellow square displays the comment. You can use this to describe the type of unit so you do not have to open Unit Properties.
Can CV-3000 and CV-5000 Series programs be used with the XG-7000 Series?
Programs of conventional image sensor models are not compatible with this system.
How do I copy a flowchart from one program to another?
Open the two programs in the XG VisionEditor, and then copy and paste the flowchart from one program to the next program.
Can I restrict access to information, such as the program settings?
Programs can be password-locked, preventing third parties from viewing or editing the programs.
Can the operations of a controller be locked to prevent tampering?
Yes. You can use passwords to switch user groups to allow or deny access with Administrators privileges and up to four user groups.
In addition to locking operations for certain user groups, you can also set which setting menu information is visible for each user group.
What are the differences in the actual operation of the various simulations and controllers?
There are differences in the waiting units and command execution. For more details, see "Overview of Simulation Functions" in chapter 7 of the XG VisionEditor Reference Manual.
What is the judgment value of an unexecuted unit?
The judgment value for an unexecuted unit is [0].
Can I change the display magnification while editing with Screen Editor?
No. The display is determined by the resolution of your computer monitor.
Can I search for a unit by unit number in Flowchart View of the XG VisionEditor?
You can search for a unit by clicking the [Jump] icon in Flowchart View.
Can I set up conditions that when satisfied exit a loop created with a loop unit?
This can be done by using a break unit. Create the flowchart so that when a condition within a loop is satisfied, the operation branches to a break unit.
How can I move multiple regions without changing their shape?
Use the [Move All Regions] function. You can select the units that you want to move and collectively reposition them without changing their shape or size.
How can I evenly align regions?
You can select the units that you want to align and use the [Align All Regions] function to evenly align them.
Does the "Outputting" status for busy global settings mean the output location of archives is also included?
No, it is not included."Outputting" means that results or images are being output by output-system units (terminal output, result output, or image output).
To view the output results of archived data, monitor [First bit: Output location data availability] for %Hist0Status to %Hist7Status.
Can a program name be read externally?
Yes, with Version 2.0 and higher. The changing of the program number (PW) is linked with changes using [Program name], and the program name can be read by using the PR (Read program number) command.
Can camera images be executed in a loop first and then image processing be performed collectively for all images later on?
Yes. By executing a loop for an image unit on the flowchart, multiple images from one camera during a single inspection can be externally controlled or continuously executed.
Is it possible to record only that inspection data which returned an NG inspection result to a computer?
Yes. You can record the desired data by executing a data output unit that outputs measurement results to the computer on the flowchart with conditional branching which treats the NG judgment of inspection data as the reference value.
Can I use an original image for the startup mode?
Yes. You can use any bitmap image at 800 × 600 pixels for the startup mode that displays when the power is turned on.
You can also display a corporate logo or other specific image in a desired location on the inspection screen.
How do I make the background of the logo image transparent?
Set the background color to R: 254, G: 1, B: 152. (This creates a pink color in a bitmap image.) See chapter 4 of the XG VisionEditor Reference Manual (Programming edition).
I don't have a console. Can I operate the system without a console?
If you have installed the XG VisionTerminal, you can use the remote desktop and directly operate the system through the console view.
Why is the double buffer disabled?
There are three conditions that must be met to enable the double buffer.
The double buffer can only be enabled when there is only one capture unit, the capture unit is at the start of the flowchart, and the image variable has not been newly defined.
Capture is executed with a terminal I/O delay unit, with the XG capture unit waiting for trigger option not selected. Can the screen be continuously updated with this setting?
No. Continuous updates can only be performed with image waiting.
When is the [%PrcTime] start point?
This is the point at which the capture unit executed first on the flowchart started capture. Therefore, units such as calculation units positioned above a capture unit are not reflected in the processing time. If no capture units exist on the flowchart, the point at which execution of the start unit begins becomes the start point.
Can the size and position of the inspection region be adjusted with the controller during inspection?
Yes. By performing the necessary settings (such as creating dialogs) for items to be adjusted in advance, you can change the size and position of the inspection region while viewing the current image at a desired timing.
What items can be changed or adjusted with the controller during inspection without having to use a computer?
In addition to viewing the image archive and statistical analysis with the function menu, you can change the setting parameters that enable variable assignment by creating dialogs. Specifically, this can be used for the upper/lower tolerance, inspection level threshold, and inspection region size and position.
What is the high speed mode "Update by user (fast)" setting in pattern search?
This mode is for performing high-speed processing while referencing variables by eliminating pattern registration processing that is performed for each conventional trigger. This mode uses both image memory, which is also used when set to [Constant (fast)], and program memory, used when set to [Update every time (slow)], so it is necessary to monitor the memory usage. Changes in the setting parameters using variable referencing are updated when you issue a RU (reference image information recalculation) command.
When does the high speed mode in pattern search switch to [Constant (fast)]?
The setting automatically switches to [Constant (fast)] when a variable is assigned to Pattern Region, Color, or Image Enhance.
When does the high speed mode of the subtraction filter switch to [Constant (fast)]?
The setting automatically switches to [Constant (fast)] when a variable is assigned to Pattern Region, Color, or Image Enhance.
When the region of the unit with the high speed mode set to "Update by user (fast)" is changed using the change region built-in dialog, no RU command is issued, but it appears as though the image reference is updated. What happened?
When the region is changed or color is extracted using a built-in dialog and [OK] is selected on the dialog, an RU command is issued automatically. An RU command must be issued when a region or filter coefficient is changed with a built-in dialog.
How much processing time is required for image operation?
The average processing times for operations between two images (full screen) with the XG7700 Series is 10 ms for 240,000 pixels, 30 ms for 1-megapixel, 60 ms for 2-megapixel, and 140 ms for 5-megapixel.Note that the processing time varies depending on pre-processing of the source image and conversion.
How can I set the condition value of conditional branching to a specific value or greater/less?
To specify conditional branching with a range of values, separate the condition once with a calculation, and then specify the branch with a value.
Arithmetic expressions cannot be used in conditional branching, so separate the condition with an IF statement calculation, and then reference that variable with conditional branching.
How will branching occur for a branch unit with condition values set to [0] and [1] and a reference value of [2]?
When the reference value does not satisfy any condition value and [ELSE] is not set as a condition value, flows in the branches are skipped and the process moves to the join unit. The result data [Branch] of the branch unit is output with 0.
What happens when the reference value of a branch unit does not match the condition value?
The operation continues forward after branching or joining while skipping units within the branch unit.
How will branching occur when, for example, the condition values of a branch unit for branches 1 and 2 are both [1] and the reference value becomes [1]?
Branching occurs for the first branch. In this example, the operation branches to branch 1.
Are variable names fixed?
The names of variables can be defined with any alphanumeric text up to 32 characters as long as the name is not reserved for system variables and restrictions on the prefix, character type, and character length are adhered to. Variables that have been defined and assigned to the flowchart can also be renamed at the same time.
How many variables can be created?
You can define up to 10,000 local variables and 1,024 global variables. You can define up to 512 image variables. (These are limited by the memory capacity range.)
What is the difference between local and global variables?
Local variables exist within the program file as variables only within that program whereas global variables exist within a gvar.dat file as common variables for all programs. You can define up to 10,000 local variables for each program and 1,028 global variables in a workspace.
Regarding the types of variable shapes, how do I use scalar, position, circle, and line objects?
Variables are not only numerical values, such as scalar-type variables, but they can also have a structure, such as position-type variables with set XY coordinates. This eliminates the need to specify X and Y separately for geometric functions.
What is the difference between system image variables and user image variables?
They are both used to store images, but whereas system image variables are cleared at the start of the flowchart, user image variables store separate information or retain stored information until a reset is performed. Also, when a user image variable is created, the double buffer is disabled.
What types of calculation functions are available?
There are 96 types of calculation functions. In addition to general arithmetic operators, trigonometric functions, and comparison operators, you can also define conditional branching (IF statements) and loop function commands (FOR statements).
How much information can be specified in a calculation unit?
Up to 1,000 characters. However, parentheses and IF, FOR, and DO LOOP statement nests have limits according to the internal memory. If this limitation is exceeded, a programming error occurs when the program is confirmed, and the cursor jumps to the beginning of the expression where the error occurred.
How can I add a visible line break to a calculation unit?
Type [space]+[underbar]+[return] at the location where you want to add a line break.
How do I search for a variable?
There are two ways to perform a search: using [Variable Reference List] and [Search].With [Variable Reference List], you can select the variable you want to find from a list of variables used in the units. Array variables are searched for regardless of the index. Meanwhile, [Search] performs a search for a variable string, so you can specify and search for index data. You can search not only for variables referenced within units but also variables used in screens and custom instructions.
How can I shorten the processing time for calculations?
You can shorten the processing time by reducing the calculations within a loop. In addition, the reading time varies depending on the type of variable. The fastest are temporary variables that start with "@" followed by global variables that start with "#" and system variables that start with "%". The slowest are result parameters and setting parameters that start with "!".
Although each of these vary slightly, the difference is more significant when used within a FOR statement.
Example: FOR @a=0 TO 49
#Dist[@a]=LnDist(Line(!U[0009].RSLT.DLXY1:AB,!U[0009].RSLT.DLXY2:AB), !U[0002].RSLT.XY[@a]:AB)
In the above example, the portion obtaining Line(!U[0009].RSLT.DLXY1:AB,!U[0009].RSLT.DLXY2:AB) within the loop is placed outside the FOR statement and stored in the #line line variable, and that line variable is referenced within the loop, thereby shortening the processing time.
FOR @a=0 TO 49
With the above changes, the processing time for calculation is shortened from 0.7 ms to 0.5 ms.
How do I copy variables that are used in multiple program numbers or workspaces?
Open the two programs in the XG VisionEditor, and then copy and paste the flowchart from one program to the next program, or copy the variables, switch programs, and paste the variables. Note that variable settings are not copied at the same time.
Do I have to assign system variables to a display pattern if I want to get an overview of the system variables during operation?
With the XG and VisionEditor connected, open [Change operating variables] in VisionEditor.
Select the variable to display and click [Get current value of controller] to display the status of the current variable.
How many elements can be placed in a display template?
Up to 4,000 including region elements for each display template.
How many page frames can be created?
Up to 99.
How many camera screens can be displayed at the same time?
Can I change the grid used for arranging parts on the Screen Editor?
You can change the color and spacing by clicking [Option] in the [Settings] field of the Screen Editor.
When multiple shapes and text are specified within a graphics unit, which is displayed in the front?
Shapes and text displayed in the bottom line within a unit are displayed in the front. You can use the ▲ and ▼ buttons to adjust the location.
When there are multiple graphics units, which unit is displayed in the front?
As a basic rule, the unit with the smaller unit number is displayed in the front. However, when a graphics unit is selected by the controller, the selected unit is displayed in the front.
When the camera image display type is a filtered image, which unit is displayed in the front?
As a basic rule, the unit with the smaller unit number is displayed in the front. However, when a unit is selected, that selected unit is displayed in the front.
Can I open the [Change Programs] dialog from a user-created dialog instead of from the function menu?
You can set the button of a user-created dialog to open a dialog (Change Programs or I/O Diagnostic) that is opened with the function menu dialog. (The program dialog number is D002.)
Can I copy created screen design settings (display template settings) to another program?
Display templates can be copied using Screen Browser of the XG VisionEditor.
Are the connections of external terminals, such as for judgment output, compatible with conventional image sensors?
The external terminals of the XG-7000 Series can be assigned by the user, but by default, the assignments are nearly compatible with the CV-5000 Series.
See the manual or contact your nearest sales representative for details.
The I/O circuit is compatible with the CV-5000 Series and can be used with a conventional terminal block and I/O cable.
How are characters and symbols used in the result output format?
These are only valid when output without protocol.
Character strings and symbols (TAB, CR, LF, CR+LF) can be output. In this case, delimiters are not output.
Example: When the format is set to [ABC] and [Edge Pos. X] is output automatically with the format, the result is output as [ABC0060038] and the comma delimiter is not output.
Normally, when [Edge Pos. X] and [Edge Pos. Y] are output continuously with the format automatically, the result is output as [0062536,0032659].
Under what circumstances is a destination file created when data is output to an SD card by a data output unit?
When the file naming rule is set to [Auto], a file is created in the following cases: when performing a reset, turning on the power, changing the program number, or when an output file does not exist on the SD card. When set to [Fixed], a file is created only when an output file does not exist on the SD card. Otherwise, a file is not created, and conditions are added to the existing file.
Can a batch setting be made to output multiple array variable values with a data output unit?
This can be set by specifying the index to start output and the number of indexes when selecting the data to output. For example, to output indexes 5 to 10 of #Dist[ ], set the data portion to #Dist[5] and the number of indexes to [6].
Can I change the destination file name of an output unit to a character string read by an OCR unit?
Yes. Use OW (Change Output Filename) and execute the [OW,nnn,xxxx
] command (nnn: unit ID, xxxx: scalar-type array variable).
Use a calculation to store the character string read by an OCR to a scalar-type array variable with one character as one element.
Example of calculation: FOR @i = 0 TO !U[0002].RSLT.CCN1:MS - 1
#FileName[@i] = !U[0002].RSLT.RCG_CHR[@i]:MS
What is "output priority" of image output?
If you try to output additional data while images are in the image buffer, the flow is stopped at that point. (Once the image buffer has available space and the transfer of queued images to the buffer is complete, operations start again.)This causes fluctuations in the processing time but all images will be output. If the buffer has available space and images have been transferred to the image buffer, the process does not stop at the output unit.
Is there a limit to the number of characters in a custom instruction?
The maximum number of alphanumeric characters is 256. (A line break is two characters.)
How many XG systems can be connected by Ethernet to one computer using the logging function of Remote Control Software "XG VisionTerminal"?
You can connect up to eight XG controllers and perform logging for the output data from each controller.
The format setting is disabled when data is output with the PLC Link, but changing the format setting changed the output data. What happened?
As part of the specifications, decimal digits can be handled in three ways depending on the format setting.
(1) Automatic
(2) When format 1 to 16 is selected and the number of decimal places is other than 0
(3) When format 1 to 16 is selected and the number of decimal places is 0

For example, when these formats are applied to measurement results and divided into these three conditions.
In the case of (1), data is output in the current state using the result data format. (The value is multiplied by 1,000 times when using decimal digits.)
 Example: ・Edge position 123.456 becomes 123456
    ・Area 123456 becomes 123456
In the case of (2), data is output with the value multiplied by 1,000 times.
 Example: ・Edge position 123.456 becomes 123456
    ・Area 123456 becomes 123456000
In the case of (3), the decimal digits are omitted.
 Example: ・Edge position 123.456 becomes 123
    ・Area 123456 becomes 123456
Can the PLC Link and CC-Link be used simultaneously?
No, they cannot. The available communication links other than the CC-Link are as follows.
When using the PLC Link (RS-232C): Ethernet can be used but RS-232C cannot be used.
When using the PLC Link (Ethernet): Ethernet cannot be used only when outputting no-protocol results but RS-232C can be used.
Can I use the same control process as that of the CV Series for PLC and I/O control? (Are the processes compatible?)
The control rules are different with the XG Series, so there is virtually no compatibility between the processes. The PLC command processing flow has also changed, so be sure to check this.
However, the I/O circuit is compatible with the CV-5000 Series and can be used with a conventional terminal block and cable.
What happens if the hard drive on the computer becomes full while data is being output from an image output unit to the XG VisionTerminal?
Image processing does not stop, but logging on the computer terminates and image output is skipped. (Communication itself is not stopped.)
Does "PC program" as the output location for archiving data in the archive logging function refer to the VisionTerminal?
This refers to VisionTerminal and ActiveX. The same applies to image output units.
For Version 1.0, this refers only to ActiveX. For image output units, this refers to VisionTerminal.
Can archived images be obtained without using an SD card?
You can obtain images on a computer by using the image archive viewer to save archives of images for the selected generation. You can also register additional images directly to the image file setting at this time.
How many archived images can be stored?
For the XG-7000 and 7500 Series, up to 501 images in 240,000-pixel monochrome mode, 53 images in 2-megapixel monochrome mode, 496 images in 240,000-pixel color mode, and 48 images in 2-megapixel color mode.
For the XG-7700 Series, up to 1,013 images in 240,000-pixel monochrome mode, 117 images in 2-megapixel monochrome mode, 40 images in 5-megapixel monochrome mode, 1,008 images in 240,000-pixel color mode, 112 images in 2-megapixel color mode, and 35 images in 5-megapixel color mode.
However, the number of images that can be stored varies depending on the defined user image variables and image memory usage when the high speed mode is set to [Update every time (slow)] when searching.
When the image archive criteria is NG with [Images] set to [Series] and [No. Archives (inc. latest)] set to [3], with the NG result occurring twice in succession, are there a total of six images remaining in the archive?
There are a total of four images. When the first NG result occurs, the NG image and the first and second images before the NG image remain in the archive. When a second NG result occurs in succession, only the NG image remains in the archive. The same image is not duplicated.
Can all images captured at high speed be saved to an SD card?
Yes, if the number of images is within the set number of images.
With the output location function, which stores captured images to the buffer memory before writing them sequentially to the SD card, all image files within the range of the number of images in the buffer memory can be saved.
What are the image formats when saving image data to an SD card or computer?
There are five types.
Select from BMP, BMP (1/2 compression), BMP (1/4 compression), BMP (1/8 compression), and JPEG.
To save a large number of images, select JPEG.   
When are statistics and archived data updated?
These are updated with the value obtained when passing through the end unit.
Can statistics be displayed on the inspection screen at the same time?
The current image and Statistics dialog can be displayed at the same time by changing the transparency of the Statistics dialog. This can be done using the View Bar or [MENU] button on the console.
How many commands can be set with one command unit?
Up to 16.Only one custom instruction can be set (but the custom instruction can have up to 16 commands).
Is there a way to detect when a command of a command unit encounters an error?
This can be done in one of two ways.
Normally, the unit judgment value of the command unit is output as the total status.
Note that [Wait Response] must be set as a condition, so a delay in the processing time of the flowchart may occur.
Also, command >internal command errors of the global settings are assigned to %Error0/1 by the user and are output. When a dialog is displayed, the error response which is useful for statistics is also displayed. However, for shared errors such as a disconnected camera, this will result in the equipment stopping due to a command error. Therefore, assignments must be carefully selected. (By default, there are no assignments.)
What happens to the remaining commands when a command error occurs during execution of multiple commands set to a command unit?
No commands are executed after an error occurs in a command unit.
The process continues to the next unit with the command only partially executed, so if variables were written, inconsistencies may occur in the results.
What happens when an error occurs in a command format for multiple commands of a command unit?
The command unit results in a unit error and the command is not executed.
In this case, the command is not output, so even the command error as the error cause is excluded.
Before uploading, this error should be determined by performing a check.
To which direct memory do I enter characters that are to be changed when a CW command of write REG is executed with PLC Link or CC-Link?
The command is CW,nnnn(unit ID),m(line number),*01.Specify the characters that are to be changed to a direct memory that supports *01 (command parameter), with a value that complies with the character code table (see chapter 6 "Built-in instruction" of the XG VisionEditor Reference Manual (Programming edition)) for the OCR unit. When there are multiple characters, this is specified with two words per character from the direct memory supporting *01. (Up to 20 characters can be changed.)
For example, to change 123 and REG, when the DM supporting *01 is 700, enter 49 for DM700, 50 for DM702, 51 for DM704, and 0 for DM706. (When a direct memory storing 0 is reached, reading finishes.)
Can the date and time setting of the system be changed externally?
This setting can be changed using the TW command.
When I try to change the shape of a region, the [Operations for variable referencing cancelation not allowed] message appears and I cannot make changes.
If variable referencing cancelation has been disabled in the account privileges setting, changes to variable referencing cancelation (such as changing a variable-assigned rectangular area to an arc) cannot be performed.
When I try to delete a subtraction filter, the [Changes to high speed mode not allowed] message appears and I cannot delete the subtraction filter.
A subtraction filter can only be deleted when the high speed mode is set to [Constant (fast)].
To disable a subtraction filter when the high speed mode is set to another setting, change the subtraction count to 0 in the parameters.
I accidentally canceled a variable assignment with an edit unit dialog. Can it be restored?
As a basic rule, this cannot be restored.
However, this can be restored if you select [Cancel] before closing the dialog used to cancel the variable assignment.
When opening an edit unit dialog, the [This dialog cannot be operated because there is an unrecoverable setting error in this unit] message appears and the unit cannot be set.
This may occur when opening an edit unit dialog for a unit with a setting error.
For example, when an invalid variable or data is assigned, the edit unit dialog cannot be used to make changes so this message appears. However, as an exception, you can open [Inspection Region], [Color] and other [Unspecified errors] that can be set with an edit unit dialog.
I upgraded the version of the controller to 2.1, but the [Edit unit] button does not appear on the function menu.
The global settings of the controller are in a format supported by Version 2.0 or earlier.
You can check the file version of program files by clicking [System Configuration] > [System Information].
What settings are required to use the edit unit dialogs?
The file version of the program file must be 2.1 or later.
In addition, edit unit dialogs can be used when the [Expand controller adjustment functions] and [Select units for editing] options are enabled. You do not need to make changes to completed flowchart items or define or assign new variables.
Which units have edit unit dialogs that support setting changes?
All measurement units as well as capture units and image operation units. All other units do not support setting changes.
Can I use an edit unit dialog to change only a specific unit?
When opening an edit unit dialog from the launcher dialog, use the [Select units for editing] option to select from the corresponding units currently set in the flowchart. You can also make corresponding units always editable.
When an edit unit dialog is opened directly with a command, you can also change corresponding units not selected with the [Select units for editing] option.
What settings can be edited with the edit unit dialogs?
Most items of corresponding units can be edited.
Whether an item can be edited or not is indicated in the list of setting data of the XG VisionEditor Reference Manual (Programming edition).
Some supported items must also be set or have variable assignments on the VisionEditor (such as [Count]).
Do variables need to be assigned to settings that will be changed with an edit unit dialog?
No, they do not as a basic rule.
As an exception, a resultant image variable must be assigned with the VisionEditor for an image operation and scalar array variable storing a filter coefficient assigned to an advanced custom filter. All other items can be changed without assigning variables.
Note that although values can be changed even when a variable is assigned, selecting [Clear] clears the variable assignment and this cannot be restored. (The variable may be canceled automatically, such as when the shape of a region is changed while a variable is assigned to the region coordinates.)
In addition, when a system variable is assigned, that item cannot be changed.
How much program memory is used with the [Expand controller adjustment function] option when using the edit unit dialogs?
This depends on the flowchart setting status.
Generally, the more units and the more unit result items there are, the more memory that is required. In addition, the use of image operations also uses image memory.
What settings are required to change [Count] for blobs and other items with the edit unit dialogs?
For blobs and other items with file version 2.1 or later, the [Allow change in count value with controller] setting is added. By enabling this setting and setting [Maximum], the controller can be used to change the count in the range of the [Maximum] setting.
How can I open an edit unit dialog with a direct open button?
The desired edit unit dialog (launcher dialog, top dialog, sub dialog) can be opened directly by specifying the dialog ID with a command, just like other dialogs. The dialog ID is increased to eight digits, enabling the use of conventional DO commands as well as dedicated BU commands.
What is the advantage of selecting [Regist. Img.] as the display image of an edit unit dialog?
Just like the CV Series, use of a registered image enables the display of the measurement result, so not only are multiple unit settings possible with the registered image as a reference, as long as the registered image is prepared correctly, the process from setting to results can be completed without preparing the actual image.
What is the [Update Ref. Val.] function on the launcher dialog?
This updates the reference value of all position adjustment units set in the flowchart with the measurement results calculated using the registered image. (By default, this is disabled.)
When the position adjustment source and target settings are changed on the registration screen, and then the reference value is updated, the position adjustment settings are completed.
Note that the reference value may not be updated correctly depending on the settings.
Can edit unit dialogs also be used by individual simulators in VisionEditor?
Edit unit dialogs can be used by individual simulators.
Settings can be adjusted in a manner similar to that of the CV simulator.
However, [Reload active inspection] must be executed after exiting the simulator so that the changes in the simulator do not overwrite the program file on the workspace.
READY output and other output turn on and off frequently and the external device malfunctions during settings with the edit unit dialogs.
In the [Disable Function] setting of the launcher unit, select trigger input off and output off so as to fix [Ready] to [Off] and [Data output] to [Off (Normal state)] when opening an edit unit dialog under the top dialog can be performed.
Note that the XG Series does not have [Program mode] and that the edit unit dialog setting also has [Run mode].
Can a unit with an unspecified error in [Inspection Region] or [Color] be reset with an edit unit dialog?
Units with normal setting errors cannot be set with the edit unit dialogs, but as an exception, [Inspection Region] and [Color] can be set.
However, because variable assignment settings and, in the case of regions, position adjustment assignments and changes are not supported, the same setting changes as that of VisionEditor cannot always be made with a controller.
When are changes to the settings with the edit unit dialogs applied?
Once changes are made (confirmed), they are applied immediately.
Can I select which edit unit dialogs are executable?
Can I add, delete, and change the order of preprocessing with an edit unit dialog?
However, custom dialogs cannot be added.
To change the order, use the No. 1 or No. 7 button + up/down.
What happens to the changes when an edit unit dialog is used to change the parameters on the system and then the settings are uploaded to the VisionEditor?
The changes are overwritten by the data in the VisionEditor.
When an edit unit dialog is used to change parameters that do not have variable assignments, the setting data is rewritten, so the changes are overwritten. When changing parameters with variable assignments, you can of course select whether or not to keep the default settings of the upload target.
I changed the scale value with [Scale Factor], but it was not applied to the measurement value of the unit. What happened?
Set scaling to [ON] with [Tool Parameters] of [Unit Properties] for the unit to which scaling is applied. By default, this is set to [OFF].
The unit setting is correct, but the edge graph is not displayed. What happened?
[Regions] in Screen Properties of the camera screen may be set to [All].In this case, the edge graph is not displayed. The edge graph is only displayed when this is set to [Single].
I accidentally deleted a unit. Can it be restored?
You can use the [Undo] function to undo the last two operations in Flowchart View or the last eight operations on the Screen Editor. You can also use [Ctrl+z] to undo an operation.
When an error occurs in a mathematical expression, the lines thereafter are not executed.
That is correct. When an error occurs in a mathematical expression, calculations thereafter are not executed. If the numerical values from a calculation are not stored correctly, check for a unit error.
I cannot set the filter coefficient with an advanced custom filter.
The scalar array variable for storing the filter coefficient must be defined as a user variable. Define a scalar array variable appropriate for the filter size.
For example, for a filter size of 21×21, define a scalar array variable with 441 or more elements.
A waiting unit is not operating properly in an individual simulator.
Waiting units other than user menu units do not work in an individual simulator. For more details, see "Overview of Simulation Functions" in chapter 7 of the XG VisionEditor Reference Manual.
I tried to add Version 2.0 functions to a setting created with Version 1.0, but an error occurred.
Functions cannot be added until the setting itself is converted to Version 2.0 format. In VisionEditor, select [File] and [Save in another file format] to save the setting in the Version 2.0 format. It is important to note that the global setting also has a version.
I uploaded global settings data but cannot update it.
Restart the controller. Unlike program data, global settings data is not updated until the controller is restarted.
In VisionEditor Version 2.0 and later, the global settings data can be updated by restarting the controller from VisionEditor without having to cycle the power of the system.
I used the controller to set the shutter speed and other camera settings, but they have not been applied to the camera.
By default, the camera settings can only be adjusted with the capture unit of the XG VisionEditor. Changes to the camera settings on the controller are not applied. To change the camera settings on the controller, select the [Use system settings] option on the [Capture Opt.] tab of the capture unit.
When a trigger is input from the handheld controller, capture is not executed.
It may be that the capture unit is not under the start unit, execution waiting (such as terminal execution waiting) is above the capture unit, and that unit has not been executed. Contact your nearest sales representative for details.
Trigger input occurred, but the image data on the monitor has not been updated.
When the flowchart reaches the end unit, the image data is updated. The process may have stopped at a point in the middle of the flowchart. Check if %WaitReady is ON to see if the flowchart is in waiting status. Contact your nearest sales representative for details.
The simulator dialog was used to change values, but they have not been applied to the settings. How do I apply the changes with the simulator?
Select [Copy current value to initial value at save] in advance for variables used to change values with the system. After changing values with the simulator, save the settings in the simulator. (Use [Save settings] in the function menu.)Next, select [Reload active inspection] from the [File] menu for the same settings.
After adjusting and saving values on the XG system and copying the current values of variables to the initial values, I changed the flowchart with VisionEditor and uploaded it to the XG system, but the initial values of the variables adjusted on the system were reset. What happened?
The initial values of the variables were overwritten with the uploaded data.
Select [Copy current value to initial value at save] in advance for variables used to change the values with the system.
After changing the values with the system, save the values (copy the current values to the initial values), and download them (load the initial values) to the VisionEditor with the settings.
Change the flowchart on the VisionEditor side to the downloaded settings.
In Version 2.0 and later of VisionEditor, when the [Keep initial value when loading program] option is selected in the variable setting and [Target Data] is selected when uploading, settings can be uploaded without changing the initial values of the variables on the XG system by selecting [Use settings] for [Initial Values of Variables] of the inspection setting and performing an upload.
Although there is no error in the syntax of the calculation, a result is not output. How can I check the output?
A dynamic error may have occurred. Check the execution log.
I cannot confirm the cause of a dynamic error displayed in the execution log.
See [Error code] and [Error line] in [Unit Result] for the calculation unit with the error. See the User's Manual for descriptions on the error codes.
I cannot view the archive even when opening the Image Archive viewer.
To use the Image Archive viewer, you must set this in the XG VisionEditor. Select [Settings] and [Image Archive], and then select the [Enable] option for Conditions 0 to 7 to set the conditions.
%JAHold is assigned to the initial value for OUT23, but OUT23 operates differently from the OR output of the CV Series.
When the %JAHold system variable is judged as NG, output continues until the system variable is reset. The system variable that operates the same as the CV Series is %JgAll, so assign %JgAll with a global setting and terminal output. Contact your nearest sales representative for details.
I created a dialog and changed the value of the variable assigned to the numerical input box, but the change has not been applied.
Check the application timing settings in the dialog settings of the XG VisionEditor dialog.
If, for example, the confirm timing is set to [when button is pressed], the setting is not confirmed until the dialog button or bottom button is pressed. Contact your nearest sales representative for details.
The Image Archive viewer displays a black image but no archived images on the system during operation.
The archived images were overwritten with new images and erased.
To display the new images, click [Update].
On the I/O monitor, the trigger is successfully input each time, but several times it appears the trigger input is only input once.
The updates to the I/O monitor display cannot catch up to the trigger speed. To check whether the signal was turned on and off correctly, use the Trace Log viewer.
I want to input a trigger with [Wait terminal I/O], but pressing the [TRIGGER] button on the handheld controller does not input the trigger.
When using [Wait terminal I/O], trigger input can only be received from a terminal block.
To input a trigger from a handheld controller, you can use a variable delay unit as usual, but you cannot use both [Wait terminal I/O] and [Variable delay] at the same time.
In VisionEditor Version 2.0 and later, a WG (Waiting status release) command is added and [Wait terminal I/O] can be canceled by issuing a command from the handheld controller.
Do I need to create a dialog to change the shutter speed of the camera on the system?
When creating a flowchart, select the [Use system settings] option on the [Capture Opt.] tab of the capture unit.
In this way, changes made with [Camera Settings] of the [System Configuration] menu are applied to the inspection.
When the system is restarted, the program returns to [0000] but can I specify the number of the program to start?
You can set this with [Program to start up] in [System Settings] of the [Global] menu.
To clear a program, do I have to delete all Editor settings and upload the program?
You can clear all settings by initializing the system. Press and hold the [Esc] key while turning on the power to initialize the system.
Pressing the [Esc] key does not close the dialog.
This may be the startup dialog. Remove the check mark next to the initial display setting in the dialog properties. Otherwise the [Close dialog on Escape] option may not be selected.
The illumination is being controlled with a command unit, but remote capture cannot be performed properly.
Remote capture is performed only using a capture unit, so command units are not executed by the controller. To resolve this issue, save the target image with the Image Archive viewer.
Flash output signals are not displayed in the trace log.
Flash output cannot be viewed in a trace log. However, because items assigned with terminal settings of global settings are displayed in the list of items in a trace log the waveforms are not displayed and only the flash items are output.
Are all system operations recorded in the modification log?
The data recorded in the modification log is only those restricted operations that can be performed with the XG system. Note that there are many operations that are not recorded. For more details, see chapter 5 of the XG VisionEditor Reference Manual (Programming edition).Operations not listed here are not recorded.
A signal cannot be confirmed on the PLC and communications cannot be established.
Use the Trace Log viewer to check whether the XG system is outputting a signal. Use the [Global] menu to check the terminal assignments.
%Trg1Ready cannot be started when waiting with [Wait terminal I/O].
The Ready signal that is started when waiting with [Wait terminal I/O] is %WaitReady. Check that signal.
Why don't %Flash3 and %Flash4 work when using the CA-DC20E light controller unit? They light when [Continuous] is set to ON.
%Flash3 and %Flash4 are not assigned to output terminals in the input/output of the global settings. The CA-DC20E light controller unit does not require a %Flash connection, but the %Flash status is referenced internally, so won't work without a terminal assignment.
I saved a workspace to an SD card, which is inserted in the SD Card 2 slot, but I cannot load the settings with the controller. What is the problem?
The setting data of the workspace is saved, so the workspace itself is not sent to the controller. The various data (setting data, global data, etc.) can be copied to their respective hierarchies, thereby enabling transfer of the data by SD card.
Entering the RE command in wait terminal I/O state creates an error and the command is not executed.
The RE command only works for trigger wait, wait terminal I/O, or variable delay for a capture unit, but Versions 1.0.0011 and earlier do not support wait terminal I/O or variable delay. Note that user menu cannot be canceled.
Variable referencing is being used to change the registered image number; however, changing the variable does not change the registered image.
Simply changing the variable does not change the registered image. The registered image changes when the NU command is issued after the variable is changed.
After I turn on %OutDataAsyncA to H, I cannot turn it off.
%OutDataAsyncA to H can control the flowchart asynchronously, but once it is turned on, it cannot be turned off. You must manually set a command to turn it off.
How can I transfer statistics data from an SD card to a computer without removing the SD card?
You can use the VisionEditor or VisionTerminal to download files saved on an SD card. In VisionEditor, use [Controller List] in System View to select the file(s) to transfer, and then right-click and select [Download] to begin data transfer.