1. Domů
  2. Podpora
  3. Podpora pro uživatele produktů
  4. Podpora pro uživatele XG
  5. Často kladené dotazy

Často kladené dotazy

Jaké jsou požadavky pro používání řady XG-7000?
Potřebujete hardware pro provádění kontroly (řídicí jednotky a kamery) a software pro vytváření programů (XG-H7N).
Jaké typy řídicích jednotek jsou k dispozici?
K dispozici je pět typů: standardní typ, který lze připojit k digitálním kamerám KEYENCE, vysokorychlostní typ podporující 2megapixelové kamery, vysokorychlostní a vysokokapacitní typ podporující 5megapixelové kamery, standardní typ, který lze připojit k analogovým kamerám, a vysokorychlostní typ, který lze připojit k analogovým kamerám.
Jaký je rozdíl mezi typy XG7000, XG7500 a XG7700?
Liší se kamerami, které lze připojit, a rychlostí zpracování obrazu.
Lze všechny řídicí jednotky připojit ke čtyřem kamerám?
Připojením rozšiřující jednotky pro kameru lze každou řídicí jednotku napojit na čtyři kamery a provádět souběžný záznam na všech těchto kamerách.
Co je dodáváno spolu s řídicí jednotkou?
Řídicí jednotka je dodávána s nainstalovanou kartou SD (SD1), s příručkou k obsluze (velikost A4, 8 stran) a se sadou náhradních štítků pro terminály.
Je k používání řídicí jednotky zapotřebí konzola?
Veškerá nastavení potřebná pro kontrolu lze nastavit pomocí počítače, takže konzole nutná není.
K provádění nastavení na řídicí jednotce je konzole volitelná.
Lze upgradovat firmware na řídicí jednotce bez použití konzoly?
K aktualizaci firmwaru je zapotřebí samostatná konzola, neboť vstup virtuální konzoly nelze provést přes vzdálenou plochu.
Lze použít komerčně dostupnou kartu SD?
Tento systém nezaručuje používání jiných karet SD než těch, které jsou dodávány spolu s řídicí jednotkou.
Jaké typy digitálních kamer jsou k dispozici?
K dispozici je 16 typů:31 megapixelů, 200 megapixelů, 7× rychlost 31 megapixelů, 7× rychlost 100 megapixelů, 7× rychlost 200 megapixelů, 11× rychlost 500 megapixelů a kompaktní kamery. Všechny jsou k dispozici v barvě a v černobílé.
Které modely analogových kamer mají garantovaný provoz v rámci tohoto systému?
Tento systém podporuje analogové kamery vyrobené společnosti KEYENCE, Sony a Toshiba Teli. Podporované modely jsou uvedeny ve specifikacích.
Chci připojit analogovou kameru. Jak mám nastavit DIP spínače?
U CA-CM20 použijte tovární nastavení. Bližší informace naleznete v uživatelské příručce v kapitole 2 v části Instalace kamery.
Lze použít kameru s konvenčním obrazovým senzorem?
Z digitálních kamer řady XG-7000 lze použít pouze vyhrazené kamery, jejichž název modelu začíná na XG. (Kamery řady CV-5000 lze použít pouze pro vedení signálu.) Z analogových kamer lze použít CA-CM20 z kamerového systému XV-1000 včetně kabelů kamery.
Lze analogové a digitální kamery použít současně?
Z analogových kamer tento systém podporuje pouze vyhrazené modely (končící na A), takže s digitálními kamerami je použít nelze.
Podporuje tento systém ultrafialové nebo infračervené kamery?
Tento systém podporuje infračervené kamery Sony XC-EI50 a XC-EI30 (s různou velikostí CCD) a ultrafialovou kameru Sony XC-EU50.
Lze snímky z analogové kamery horizontálně obrátit?
Ano.
Jaké typy příruček jsou k dispozici?
K dispozici jsou čtyři typy příruček.
Každá z nich je dodávána ve formátu PDF spolu se softwarem XG-H7N.
(1) Uživatelská příručka XG-7000: příručka k hardwaru
(2) Referenční příručka XG VisionEditor (verze pro programování):Popisuje, jak vytvářet blokové diagramy a uživatelská rozhraní.
(3) Referenční příručka XG VisionEditor (verze pro ovládání):Popisuje, jak ovládat vstup/výstup a sériovou komunikaci.
(4) Uživatelská příručka XG VisionTerminal:Popisuje dálkové ovládání a protokolování.
Jak zobrazím příručky?
Nainstalujte XG VisionEditor a XG VisionTerminal a klikněte na nabídku Start, případně v nabídce aplikace vyberte možnost [Help] (Nápověda), odkud můžete otevřít zvolenou příručku ve formátu PDF.
Nemohu otevřít uživatelskou příručku XG-7000 User Manual (příručka k hardwaru) z nabídky Help (Nápověda) softwaru VisionEditor. Musím si tuto příručku koupit samostatně?
Tato příručka se do vašeho počítače uloží při instalaci programu VisionEditor, ale nelze ji otevřít přímo z nabídky nápovědy. Uživatelskou příručku řady XG-7000 lze otevřít z původního umístění instalace (C:Documents and SettingsAll UsersStart MenuProgramsKEYENCE ApplicationsV-Works for XG).
Jaká uživatelská podpora je k dispozici ohledně vytváření blokových diagramů?
Můžete si stáhnout ukázkové soubory a nejnovější software ze stránky uživatelské podpory XG. Vaše dotazy také rádi zodpoví zástupci technické podpory XG ve společnosti KEYENCE.
Jaké typy softwaru jsou pro tento systém k dispozici?
K dispozici jsou dva typy softwaru:Integrovaný software pro editaci obrazu XG VisionEditor a software pro dálkové ovládání XG VisionTerminal.
K čemu slouží integrovaný software pro editaci obrazu XG VisionEditor?
Tento integrovaný software pro editaci obrazu obsahuje celou řadu funkcí pro nastavení, které v počítači umožňují vytvářet toky zpracování obrazu a uživatelská rozhraní, jakož i ladění, simulace a nahrávání.
K čemu slouží software pro dálkové ovládání XG VisionTerminal?
Tento software umožňuje v počítači monitorovat a spravovat řídicí jednotku XG-7000 prostřednictvím ethernetového nebo USB připojení. Také má funkce pro monitorování většího počtu řídicích jednotek připojených k síti a funkce záznamu naměřených hodnot a obrazových dat.
Jaké jsou systémové požadavky pro spuštění integrovaného softwaru pro editaci obrazu XG VisionEditor?
Procesor:Ekvivalentní ke Core 2 Duo na 1,06 GHz nebo rychlejší (doporučujeme ekvivalentní ke Core 2 Duo na 1,80 GHz nebo rychlejší)
RAM:1 GB nebo více (doporučujeme 2 GB nebo více)
Volné místo na pevném disku:pro instalaci 600 MB nebo více, pro provoz softwaru 500 MB nebo více
Lze zakoupenou kopii softwaru XG-H7N použít na více počítačích?
K provozu softwaru XG VisionEditor potřebuje každý počítač samostatný aktivační kód.
O aktivační kód můžete požádat na stránkách uživatelské podpory XG. V zásadě je na jednu kopii XG-H7N vydáván jeden aktivační kód. Chcete-li software používat na více počítačích, je třeba si koupit více kopií softwaru.
Co je to pracovní prostor, který je používán v programu XG VisionEditor?
Jedná se o složku představující virtuální řídicí jednotku XG, která je vytvořena na pevném disku počítače. Složka pracovního prostoru obsahuje složky SD1 a SD2, které jsou pro systém ekvivalentem k jednotkám karet SD. Do každé z těchto složek lze ukládat programová data a data registrovaných snímků.
Pracovní prostor lze přepnout tak, aby z jednoho počítače bylo možné spravovat nastavení více řídicích jednotek.
Kolik programů lze vytvořit na jedné řídicí jednotce?
S použitím dvou jednotek karet SD můžete vytvořit data až pro 2000 programů. Každá karta SD může pojmout 1000 programů (od čísla 000 do 999), ale v závislosti na nastavení se může karta SD zaplnit i před dosažením 1000 programů.
Kolik dnů ze zkušebního období softwaru XG VisionEditor mi ještě zbývá?
Tuto informaci můžete odvodit podle data, kdy byla aktivována licence.
Pokud v nabídce Help (Nápověda) vyberete možnost [About...], zobrazí se okno [Extension Activation Code Input] (Zadání aktivačního kódu pro rozšíření). Toto okno obsahuje informaci o zkušebním období ve formátu „The trial period is 30 days starting (year/month/day)“ (Zkušební doba trvá 30 dní od data (rok/měsíc/den)).
Počítač, na kterém jsem provozoval(a) software XG-H7N, přestal fungovat, a proto potřebuji aktivační kód pro nový počítač. Co mám dělat?
Obraťte se na místní zastoupení společnosti KEYENCE.
Kolik jednotek může být nastaveno v blokovém diagramu?
Kromě minimálního počtu požadovaných jednotek lze celkem nastavit až 1 000 jednotek nebo 997 měrných jednotek. (Aktuální počet jednotek, které lze nastavit, závisí na kapacitě paměti systému.)
Lze v seznamu zobrazit i blokový diagram, který je tak dlouhý,že se nevejde do zobrazení blokového diagramu?
Velikost zobrazení lze změnit úpravou poměru zvětšení možnosti Flowchart View (Zobrazení blokového diagramu) pod volbou Window (Okno) na liště nabídek.
Jak do řídicí jednotky přenesu program vytvořený na počítači?
Soubor vytvořený pomocí programu XG VisionEditor lze přenést dvěma způsoby: můžete jej nahrát, když se k řídicí jednotce připojíte kabelem USB nebo ethernetovým kabelem, nebo data zapsat na kartu SD jako soubor a nechat ji v řídicí jednotce přečíst.
Vytvoří zápis dat z počítače do systému XG-7000 nějaká zpoždění při zpracování?
Když jsou data nahrána a přepsána na aktuálně používaný program, jsou resetována. Funkce programů, které právě nejsou používány, tím nebude nijak ovlivněna.
Jaké generace je nastavení souboru pro záznam?
Jedna „generaceƒ“ se počítá od spouštěcí ke koncové jednotce. Nastavení „prvního“ a „druhého“ souboru patří každé k jedné generaci.
Lze v programu XG VisionEditor provádět změny v rozložení 1 až 5?
Zobrazení a okna v programu XG VisionEditor lze libovolně nastavovat. Rozložení 1 je optimálně nastaveno pro vytváření blokového diagramu zpracování obrazu, rozložení 2 je upraveno pro vytváření uživatelského rozhraní. Rozložení 3 až 5 jsou nastavena stejně, aby je bylo možné v případě potřeby upravit.
Jak v programu XG VisionEditor resetuji pozice rozložení?
Na liště nabídek pod možností Window (Okno) vyberte možnost [Reset Layout] (Resetovat rozložení).
Co v náhledu blokového diagramu znamená žlutý čtverec vlevo dole od jednotky?
Tento symbol naznačuje, že byl k dané jednotce do tabulky [System Settings] (Systémové nastavení) přidán komentář. Komentář se zobrazí, když na jednotku se žlutým čtvercem umístíte kurzor myši. Tímto způsobem můžete popsat typ jednotky, aniž byste museli otevírat vlastnosti jednotky.
Lze se řadou XG-7000 použít programy řady CV-3000 a CV-5000?
Programy modelů konvenčních obrazových senzorů nejsou s tímto systémem kompatibilní.
Jak zkopíruji blokový diagram z jednoho programu do druhého?
Oba programy otevřete v programu XG VisionEditor, zkopírujte blokový diagram z jednoho programu a vložte jej do programu druhého.
Mohu zakázat přístup k informacím, například k nastavení programu?
Programy lze chránit heslem, aby je nemohl prohlížet ani upravovat nikdo nepovolaný.
Lze provoz řídicí jednotky zablokovat a zabránit tak neoprávněné manipulaci?
Ano. Pomocí hesel můžete jednotlivým skupinám uživatelů povolit nebo zakázat přístup k administrátorským právům. Můžete nastavit až čtyři skupiny uživatelů.
Kromě uzamčení některých operací můžete pro jednotlivé skupiny určit, v jakém nastavení se jim bude zobrazovat informační nabídka.
V čem se liší provoz různých simulací a řídicích jednotek?
Rozdíly spočívají v čekajících jednotkách a v provádění příkazů. Další informace naleznete v kapitole 7 v části Přehled funkcí simulací referenční příručky XG VisionEditor.
Jaká je posuzovací hodnota neprovedené jednotky?
Posuzovací hodnota neprovedené jednotky je [0].
Mohu během úprav v nástroji Screen Editor změnit zvětšení zobrazení?
Ne. Zobrazení je nastaveno podle rozlišení monitoru vašeho počítače.
Mohu v programu XG VisionEditor v náhledu blokového diagramu vyhledat jednotku podle čísla jednotky?
V náhledu blokového diagramu lze jednotku vyhledat kliknutím na ikonu [Jump].
Mohu nastavit podmínky, při jejichž splnění se ukončí smyčka vytvořená jednotkou smyčky?
To lze provést pomocí přerušovací jednotky. Vytvořte blokový diagram, aby se v případě, že bude splněna podmínka v rámci smyčky, operace rozvětvila na přerušovací jednotku.
Jak mohu přesunout více oblasti, aniž by bylo třeba měnit jejich tvar?
Použijte funkci [Move All Regions] (Přesunout všechny oblasti). Můžete vybrat jednotky, které chcete přesunout, a společně je přemístit, aniž byste přitom měnili jejich tvar nebo velikost.
Jak mohu stejnoměrně zarovnat oblasti?
Můžete vybrat jednotky a stejnoměrně je zarovnat pomocí funkce [Align All Regions] (Zarovnat všechny oblasti).
Pokud se u vytíženého globálního nastavení zobrazuje stav Outputting (Výstup), znamená to, že zahrnuje i umístění výstupu archivů?
Ne, neznamená. Stav Outputting znamená, že výsledky nebo snímky vycházejí z výstupních systémových jednotek (terminálový výstup, výstup výsledků nebo obrazový výstup).
Chcete-li zobrazit výsledky výstupu archivovaných dat, sledujte [First bit:Output location data availability] pro %Hist0Status to %Hist7Status.
Lze název programu přečíst externě?
Ano, ve verzi 2.0 a vyšší. Změna čísla programu (PW) je spojena se změnami pomocí [Program name] (Název programu) a název programu si lze přečíst pomocí příkazu PR (číslo čteného programu).
Lze snímky z kamery provést nejprve ve smyčce a zpracování obrazu provést později hromadně pro všechny snímky?
Ano. Provedením smyčky pro obrazovou jednotku v blokovém diagramu lze během jedné kontroly externě ovládat nebo průběžně zpracovávat větší počet obrazů z jedné kamery.
Je možné do počítače zaznamenat pouze ta data, která vrátila výsledek kontroly jako NG?
Ano. Požadovaná data můžete zaznamenat provedením jednotky datového výstupu, která výsledky měření přenese do počítače na blokovém diagramu s podmíněným rozvětvením, které považuje posouzení NG dat kontroly za referenční hodnotu.
Mohu pro spouštěcí režim použít původní snímek?
Ano. Pro spouštěcí režim, který se zobrazuje při zapnutí napájení, můžete použít jakýkoli bitmapový obrázek v rozlišení 800×600 pixelů.
Na zvoleném místě kontrolní obrazovky také můžete zobrazit společné logo nebo jiný zvolený obrázek.
Jak u obrázku loga vytvořím průhledné pozadí?
Nastavte barvu pozadí na R:254, G:1, B:152.(Na bitmapovém obrázku tak vznikne růžové zabarvení.) Bližší informace najdete v kapitole 4 referenční příručky XG VisionEditor (verze pro programování).
Nemám konzolu. Mohu systém ovládat i bez konzoly?
Máte-li nainstalován program XG VisionTerminal, můžete se systémem pracovat přímo přes konzolové zobrazení pomocí vzdálené plochy.
Proč je vypnuta dvojitá vyrovnávací paměť?
Pro aktivaci dvojité vyrovnávací paměti musí být splněny tři podmínky.
Dvojitou vyrovnávací paměť lze aktivovat pouze tehdy, je-li k dispozici pouze jedna záznamová jednotka, která se nachází na začátku blokového diagramu a obrazová proměnná nebyla nově definována.
Záznam se provádí pomocí zpožďovací jednotky vstupu/výstupu terminálu, kdy není vybrána možnost záznamové jednotky XG čekající na spuštění. Může být obrazovka pomocí tohoto nastavení průběžně aktualizována?
Ne. Průběžné aktualizace lze provádět pouze v případě čekajícího obrazu.
Kdy nastává počáteční bod [%PrcTime]?
Jedná se o bod, kdy záznam začne provádět záznamová jednotka, uvedená na blokovém diagramu jako první. Do doby zpracování se proto nezapočítávají např. výpočtové jednotky, které jsou uvedeny nad záznamovou jednotkou. Pokud se v blokovém diagramu žádné záznamové jednotky nenacházejí, bude počátečním bodem okamžik spuštění spouštěcí jednotky.
Lze během kontroly upravit velikost a pozici kontrolní oblasti pomocí řídicí jednotky?
Ano. Pokud předem provedete veškerá potřebná nastavení (například vytvoření dialogů) položek, které mají být upraveny, můžete změnit velikost a pozici kontrolní oblasti v určeném časování během prohlížení aktuálního obrazu.
Jaké položky lze během kontroly změnit nebo upravit pomocí řídicí jednotky, aniž by bylo třeba použít počítač?
Kromě zobrazení archivu snímků a statistické analýzy s nabídkou funkce můžete změnit parametry nastavení, které umožní přiřadit proměnnou pomocí vytváření dialogů. Tuto možnost lze použít zvláště pro horní/dolní toleranci, práh úrovně kontroly a velikost a pozici kontrolované oblasti.
K čemu slouží nastavení vysokorychlostního režimu „Update by user (fast)“ (Aktualizovat uživatelem (rychle)) ve vyhledávání vzoru?
Tento režim je určen k provádění vysokorychlostního zpracování, kdy je současně odkazováno na proměnné eliminováním zpracování registrace vzoru, které se provádí pro každý běžný spouštěč. Tento režim pracuje jak s obrazovou pamětí, která se také používá v nastavení na [Constant (fast)] (Konstantní (rychlé)), tak i s programovou pamětí použitou v nastavení [Update every time (slow)] (Aktualizovat pokaždé (pomalé)). Proto je třeba využití paměti sledovat. Změny v parametrech nastavení pomocí odkazů na proměnné se aktualizují, když vydáte příkaz RU (přepočítání informací referenčního obrazu).
Kdy se vysokorychlostní režim v přepínači vyhledávání vzoru přepne na [Constant (fast)] (Konstantní (rychlé))?
Toto nastavení se automaticky přepne na [Constant (fast)] (Konstantní (rychlé)), je-li k možnosti Pattern Region (Oblast vzoru), Color (Barva), nebo Image Enhance (Vylepšení obrazu) přiřazena proměnná.
Kdy se vysokorychlostní režim odlučovacího filtru přepne na [Constant (fast)] (Konstantní (rychlý))?
Toto nastavení se automaticky přepne na [Constant (fast)] (Konstantní (rychlé)), je-li k možnosti Pattern Region (Oblast vzoru), Color (Barva), nebo Image Enhance (Vylepšení obrazu) přiřazena proměnná.
Když je oblast jednotky s vysokorychlostním režimem nastaveným na „Update by user (fast)“ (Aktualizovat uživatelem (rychlé)) změněna pomocí vestavěného dialogu změny oblasti, není vydán žádný příkaz RU, ale zdá se, jako by byl aktualizován odkaz na obrázek. Co se stalo?
Je-li pomocí vestavěného dialogu změněna oblast nebo je extrahována barva a volba je potvrzena pomocí [OK], příkaz RU je vydán automaticky. Příkaz RU musí být vydán, pokud je koeficient oblasti nebo filtru změněn pomocí vestavěného dialogu.
Jak dlouho trvá zpracování obrazu?
Zpracování úkonů mezi dvěma snímky (v režimu plné obrazovky) trvá řadě XG7700 průměrně 10 ms pro 240 000 pixelů, 30 ms pro 1 megapixel, 60 ms pro 2 megapixely a 140 ms pro 5 megapixelů. Doba zpracování se dále může lišit v závislosti na předběžném zpracování a konverzi zdrojového obrazu.
Jak mohu nastavit hodnotu podmínky podmíněného větvení na určitou hodnotu nebo na vyšší/nižší?
Chcete-li specifikovat podmíněné větvení s rozsahem hodnot, jednou oddělte podmínku výpočtem a poté větvení specifikujte hodnotou.
Pro podmíněné větvení nelze použít aritmetické výrazy, proto podmínky oddělujte výpočtem údaje IF a potom tuto proměnnou odkazujte na podmíněné větvení.
Jak bude větvení probíhat u jednotky s hodnotami podmínky nastavenými na [0] a [1] a referenční hodnotou [2]?
Jestliže referenční hodnota neodpovídá žádné hodnotě podmínky a [ELSE] není nastavena jako hodnota podmínky, toky ve větvích budou přeskočeny a proces se přesune do spojovací jednotky. Výsledná data [Branch] jednotky větvení budou mít výstup 0.
Co se stane, když referenční hodnota jednotky větvení neodpovídá hodnotě podmínky?
Proces bude po větvení nebo spojení pokračovat dál, zatímco jednotky v rámci jednotky větvení budou přeskočeny.
Jak bude větvení probíhat v případě, že například hodnoty podmínek jednotky větvení pro větve 1 a 2 budou mít stejnou hodnotu [1] a referenční hodnota bude také [1]?
Větvení proběhne na první větvi. V tomto případě se proces rozvětví na větev 1.
Jsou názvy proměnných pevně dané?
Názvy proměnných lze definovat jakýmkoli alfanumerickým textem o délce do 32 znaků, pokud název není rezervován pro proměnné systému. Přitom je třeba dodržovat omezení pro předponu, typ znaku a délku znaku. Proměnné, které byly definovány a přiřazeny k blokovému diagramu, lze současně přejmenovávat.
Kolik proměnných lze vytvořit?
Můžete definovat až 10 000 lokálních proměnných a 1 024 globálních proměnných. Můžete definovat až 512 obrazových proměnných. (Ty jsou omezeny rozsahem kapacity paměti.)
Jaký je rozdíl mezi lokální a globální proměnnou?
Lokální proměnné existují v rámci programového souboru jako proměnné, které jsou určeny pouze pro daný program, zatímco globální proměnné jsou uloženy v souboru gvar.dat jako společné proměnné pro všechny programy. Můžete definovat až 10 000 lokálních proměnných pro každý program a 1 028 globálních proměnných v pracovním prostoru.
Co se týče tvarů proměnných, jak mohu používat skalární, polohové, kruhové a liniové objekty?
Proměnné nejsou pouze numerické hodnoty, například proměnné skalárního typu, ale mohou mít i strukturu, například proměnné polohového typu s nastavenými souřadnicemi XY. Tím se eliminuje potřeba samostatně specifikovat X a Y pro geometrické funkce.
Jaký je rozdíl mezi systémovými a uživatelskými obrazovými proměnnými?
Oboje tyto proměnné slouží k ukládání snímků, ale zatímco systémové obrazové proměnné jsou na začátku blokového diagramu vymazány, uživatelské obrazové proměnné ukládají samostatné informace nebo uchovávají uložené informace, dokud není proveden reset. Jakmile je vytvořena uživatelská obrazová proměnná, deaktivuje se dvojitá vyrovnávací paměť.
Jaké typy výpočtových funkcí jsou k dispozici?
K dispozici je 96 typů výpočtových funkcí. Kromě obecných aritmetických operátorů, trigonometrických funkcí a srovnávacích operátorů můžete definovat i příkazy pro podmíněné větvení (údaje IF) a funkci smyčky (údaje FOR).
Jaké množství informací lze specifikovat ve výpočtové jednotce?
Až 1 000 znaků. Závorky a vnoření údajů IF, FOR a DO LOOP jsou však limitovány vnitřní pamětí. Je-li toto omezení překročeno, program při potvrzování zahlásí chybu programování a kurzor přeskočí na začátek výrazu, ve kterém se chyba vyskytuje.
Jak mohu do výpočetní jednotky vložit zalomení viditelné linie?
Na místo, kam chcete vložit zalomení linie, napište [mezerník]+[dolní vodorovný pruh]+[enter].
Jak mohu vyhledat proměnnou?
Vyhledání lze provést dvěma způsoby: pomocí seznamu odkazů na proměnné [Variable Reference List] a pomocí vyhledání [Search]. Při vyhledávání pomocí [Variable Reference List] můžete hledanou proměnnou vybrat ze seznamu proměnných použitých v jednotkách. Proměnné pole jsou vyhledávány bez ohledu na index. Mezitím [Search] vyhledá řetězce proměnných, takže můžete specifikovat a vyhledat indexová data. Vyhledávat lze nejen proměnné, na které je odkazováno v rámci jednotek, ale i proměnné použité na obrazovkách a ve vlastních příkazech.
Jak mohu zkrátit dobu zpracování výpočtů?
Dobu zpracování můžete zkrátit omezením výpočtů v rámci smyčky. Doba čtení navíc závisí na typu proměnné. Nejrychlejší jsou dočasné proměnné začínající znakem @, následují globální proměnné začínající znakem # a systémové proměnné začínající znakem %. Nejpomalejší jsou parametry výsledků a parametry nastavení, které začínají znakem !.
Přestože se mírně liší, rozdíl je výraznější v případě, že jsou použity v údaji FOR.
Například:FOR @a=0 TO 49
#Dist[@a]=LnDist(Line(!U[0009].RSLT.DLXY1:AB,!U[0009].RSLT.DLXY2:AB), !U[0002].RSLT.XY[@a]:AB)
NEXT
V této ukázce je ve smyčce část získávající Line(!U[0009].RSLT.DLXY1:AB,!U[0009].RSLT.DLXY2:AB) umístěna mimo údaj FOR a uložena v řádkové proměnné #line, a tato řádková proměnná je odkazována v rámci smyčky, čímž se doba zpracování zkrátí. #line=Line(!U[0009].RSLT.DLXY1:AB,!U[0009].RSLT.DLXY2:AB)
FOR @a=0 TO 49
#Dist[@a]=LnDist(#line,!U[0002].RSLT.XY[@a]:AB)
NEXT
S výše uvedenými změnami se doba zpracování výpočtu zkrátí z 0,7 ms na 0,5 ms.
Jak zkopíruji proměnné, které jsou použity v několika programech nebo pracovních prostorech?
Dva programy otevřete v programu XG VisionEditor, kde můžete zkopírovat blokový diagram z jednoho programu a vložit jej do programu druhého, případně zkopírovat proměnné, přepnout programy a proměnné vložit. Mějte na paměti, že nastavení proměnných se najednou nezkopíruje.
Musím k zobrazovacímu vzorci přiřadit systémové proměnné, když chci získat přehled o systémových proměnných během procesu?
Máte-li připojeny XG a VisionEditor, v programu VisionEditor otevřete [Change operating variables] (Změna operačních proměnných).
Vyberte proměnnou, kterou chcete zobrazit, a kliknutím na [Get current value of controller] (Získat aktuální hodnotu řídicí jednotky) zobrazíte stav aktuální proměnné.
Kolik prvků lze umístit na šablonu zobrazení?
Až 4 000 včetně prvků oblasti pro každou šablonu zobrazení.
Kolik rámů stránky lze vytvořit?
Až 99.
Kolik obrazovek kamery je možné zobrazit zároveň?
Pět.
Mohu v editoru obrazovky změnit mřížku použitou k uspořádání součástí?
V editoru obrazovky můžete kliknutím na [Option] (Možnost) v poli [Settings] (Nastavení) změnit barvu a mezery.
Je-li v grafické jednotce specifikováno více tvarů, který se bude zobrazovat jako první?
Tvary a text uvedené ve spodním řádku jednotky budou zobrazeny na začátku. Pozici můžete upravit tlačítky ▲ a ▼.
Existuje-li více grafických jednotek, která z nich se zobrazí na začátku?
Podle základního pravidla se na začátku zobrazí jednotka s nižším číslem jednotky. Je-li však řídicí jednotkou vybrána jednotka grafická, pak bude na začátku zobrazena vybraná jednotka.
Když je displej kamery nastaven na filtrovaný obraz, která jednotka se zobrazí na začátku?
Podle základního pravidla se na začátku zobrazí jednotka s nižším číslem jednotky. Je-li však některá jednotka vybrána, zobrazí se na začátku.
Mohu otevřít dialog [Change Programs] (Změnit programy) z uživatelem vytvořeného dialogu namísto z nabídky funkcí?
Můžete nastavit, aby tlačítko uživatelem vytvořeného dialogu otevíralo dialog (Change Programs (Změnit programy) nebo I/O Diagnostic (Diagnostika vstupu/výstupu)), který je otevřen pomocí dialogu nabídky funkcí. (Dialogové číslo programu je D002.)
Mohu vytvořená nastavení návrhu obrazovky (nastavení šablony zobrazení) zkopírovat do jiného programu?
Šablony zobrazení lze v programu XG VisionEditor kopírovat pomocí nástroje Screen Browser.
Je připojení externích terminálů, například pro výstup posuzování, kompatibilní s konvenčními obrazovými senzory?
Externí terminály řady XG-7000 může uživatel přiřadit, ale ve výchozím nastavení jsou přiřazení víceméně kompatibilní s řadou CV-5000.
Bližší informace naleznete v uživatelské příručce, nebo se obraťte na svého obchodního zástupce.
Vstup/výstup obvodu je kompatibilní s řadou CV-5000 a lze jej použití s konvenčním terminálem a vstupem/výstupem kabelu.
Jak se ve výsledném výstupním formátu používají znaky a symboly?
Jsou platné pouze při výstupu bez protokolu.
Výstupem mohou být řetězce znaků a symboly (TAB, CR, LF, CR+LF). V tomto případě nejsou výstupem oddělovače.
Například:Je-li formát nastaven na [ABC] a spolu s formátem je automatickým výstupem [Edge Pos. X] (Poloha okraje X), je výsledným výstupem [ABC0060038] (čárka jako oddělovač výstupem není).
Pokud jsou s formátem jako výstup automaticky uváděny hodnoty [Edge Pos. X] a [Edge Pos. Y], je výsledným výstupem [0062536,0032659].
Za jakých okolností je cílový soubor vytvořen, když se výstupní data ukládají na kartu SD pomocí výstupní datové jednotky?
Je-li pravidlo názvů souborů nastaveno na [Auto], bude soubor vytvořen v následujících případech: při provádění resetování, při zapnutí, při změně čísla programu nebo když výstupní soubor na kartě SD neexistuje. Je-li pravidlo nastaveno na [Fixed] (Pevný), bude soubor vytvořen pouze v případě, že výstupní soubor na kartě SD neexistuje. Jinak soubor vytvořen nebude a podmínky budou přidány k souboru již existujícímu.
Lze provést dávkové nastavení pro výstup více proměnných hodnot pole pomocí jednotky výstupu dat?
Toto nastavení lze provést zadáním indexu pro spuštění výstupu a počtu indexů při výběru dat pro výstup. Například pro výstupní indexy 5 až 10 z #Dist[ ] je třeba nastavit dávku dat na #Dist[5] a počet indexů na [6].
Mohu změnit název cílového souboru výstupní jednotky na řetězec znaků přečtených jednotkou OCR?
Ano. Použijte OW (Change Output Filename (Změna názvu výstupního souboru)) a proveďte příkaz [OW,nnn,xxxx
] (nnn: unit ID, xxxx: proměnná pole skalárního typu).
Řetězec znaků přečtený OCR uložte pomocí výpočtu do proměnné pole skalárního typu, kdy jeden znak představuje jeden prvek.
Příklad výpočtu:FOR @i = 0 TO !U[0002].RSLT.CCN1:MS - 1
#FileName[@i] = !U[0002].RSLT.RCG_CHR[@i]:MS
NEXT
#FileName[@i]=0
Co u obrazového výstupu znamená „priorita výstupu“?
Pokud se pokusíte provést výstup dalších dat, zatímco jsou v obrazové vyrovnávací paměti uloženy snímky, tok se v tomto bodě zastaví. (Jakmile se v obrazové vyrovnávací paměti uvolní místo a přenos čekajících snímků bude dokončen, provoz bude opět zahájen.) Znamená to sice fluktuace v době zpracování, ale do výstupu se dostanou všechny snímky. Je-li ve vyrovnávací paměti místo a snímky byly přeneseny do obrazové vyrovnávací paměti, proces se na výstupní jednotce nezastaví.
Existuje nějaké omezení pro počet znaků vlastního příkazu?
Maximální počet alfanumerických znaků je 256.(Zalomení řádku se počítá jako dva znaky.)
Kolik systémů XG lze připojit přes ethernet k jednomu počítači pomocí protokolovací funkce softwaru „XG VisionTerminal“ pro vzdálené řízení?
Můžete připojit až šest řídicích jednotek XG a z každé z nich provádět protokolování výstupních dat.
Nastavení formátu je zakázáno, je-li pro výstup dat použita jednotka PLC Link, ale změnou nastavení formátu došlo ke změně výstupních dat. Co se stalo?
V rámci specifikací lze číslice desítkové soustavy zpracovávat třemi způsoby podle toho, jaký formát je nastaven.
(1) Automaticky
(2) Je-li vybrán formát 1 až 16 a počet desetinných míst je jiný než 0
(3) Je-li vybrán formát 1 až 16 a počet desetinných míst je 0

Například když jsou tyto formáty aplikovány na výsledky měření a rozděleny podle těchto tří podmínek.
V případě (1) jsou data při výstupu v aktuálním stavu pomocí formátu výsledných dat. (Jsou-li použity desetinné číslice, je hodnota násobena 1 000.)
 Příklad:・Poloha okraje 123,456 bude 123456
    ・Oblast 123456 bude 123456
V případě (2) bude výstupní hodnota dat násobena 1 000.
 Příklad:・Poloha okraje 123,456 bude 123456
    ・Oblast 123456 bude 123456000
V případě (3) budou desetinná místa vypuštěna. Příklad:・Poloha okraje 123,456 bude 123
    ・Oblast 123456 bude 123456
Lze jednotky PLC Link a CC-Link použit současně?
Ne, nelze. Kromě CC-Link jsou k dispozici následující datové spoje.
Používáte-li PLC Link (RS-232C):Lze použít ethernet, ale RS-232C nikoli.
Používáte-li PLC Link (Ethernet):Ethernet nelze použít pouze v případě výstupu výsledků bez protokolu, RS-232C však použít lze.
Mohu pro ovládání PLC a vstupu/výstupu použít stejný kontrolní proces jako u řady CV? (Jsou tyto procesy kompatibilní?)
Pravidla ovládání jsou u řady XG jiné, takže tyto procesy spolu v podstatě kompatibilní nejsou. Změnil se i tok zpracování příkazu PLC, proto zkontrolujte i tento aspekt.
Vstup/výstup obvodu je však kompatibilní s řadou CV-5000 a lze jej použít s běžnou jednotkou terminálu a kabelem.
Co se stane, když se ve chvíli, kdy dochází k výstupu dat z jednotky obrazového výstupu do programu XG VisionTerminal, naplní kapacita pevného disku v počítači?
Zpracování obrazu se nezastaví, ale bude ukončeno přihlášení do počítače a obrazový výstup bude přeskočen. (Samotná komunikace přerušena nebude.)
Odkazuje „PC program“ jako výstupní umístění pro archivaci dat ve funkci protokolování archivu na program VisionTerminal?
Odkazuje na program VisionTerminal a ActiveX. To samé platí pro jednotky obrazového výstupu.
V případě verze 1.0 tato skutečnost platí pouze pro ActiveX. V případě jednotek obrazového výstupu se toto týká programu VisionTerminal.
Lze archivované snímky získat i bez použití karty SD?
Snímky lze na počítači získat pomocí prohlížeče archivu snímků a uložit archivy snímků zvolené generace. Přitom můžete zaregistrovat další obrázky přímo do nastavení obrazového souboru.
Kolik archivovaných snímků lze uložit?
V případě řady XG-7000 a 7500 je to 501 snímků v černobílém režimu s rozlišením 240 000 pixelů, 53 snímků v černobílém režimu s rozlišením 2 megapixely, 496 snímků v barevném režimu s rozlišením 240 000 pixelů a 48 snímků v barevném režimu s rozlišením 2 megapixely.
V případě řady XG-7700 je to 1 013 snímků v černobílém režimu s rozlišením 240 000 pixelů, 117 snímků v černobílém režimu s rozlišením 2 megapixely, 40 snímků v černobílém režimu s rozlišením 5 megapixelů, 1 008 snímků v barevném režimu s rozlišením 240 000 pixelů, 112 snímků v barevném režimu s rozlišením 2 megapixely a 35 snímků v barevném režimu s rozlišením 5 megapixelů.
Počet uložených snímků však závisí na uživatelem definovaných obrazových proměnných a využití obrazové paměti v případě, že je vysokorychlostní režim při vyhledávání nastaven na [Update every time (slow)] (Aktualizovat pokaždé (pomalé).
Je-li kritérium pro archivaci snímků NG, [Images] (Snímky) nastaveny na [Series] (Série) a [No. Archives (inc. latest)] (Poč. archivů (včetně nejnovějších)) nastaveno na [3] a výsledek NG nastane dvakrát po sobě, bude v archivu zbývat celkem šest snímků?
V archivu budou celkem čtyři snímky. Když nastane první výsledek NG, v archivu zůstane snímek NG a první a druhé snímky před snímkem NG. Když následně nastane druhý výsledek NG, v archivu zůstane pouze snímek NG. Stejné snímky se neduplikují.
Lze všechny snímky zaznamenané při vysoké rychlosti uložit na kartu SD?
Ano, pokud počet snímků spadá do nastaveného počtu snímků.
Pomocí funkce výstupního umístění, která zaznamenané snímky před postupným zápisem na SD kartu ukládá do vyrovnávací paměti, lze uložit všechny obrazové soubory v rozsahu počtu snímků ve vyrovnávací paměti.
V jakých formátech se obrazová data ukládají na kartu SD nebo do počítače?
K dispozici je celkem pět typů.
Můžete si vybrat BMP, BMP (1/2 komprese), BMP (1/4 komprese), BMP (1/8 komprese) a JPEG.
V případě, že chcete ukládat vysoký počet snímků, vyberte JPEG.   
Kdy se aktualizují statistiky a archivovaná data?
Tato data jsou aktualizována hodnotou získanou při průchodu koncovou jednotkou.
Lze na obrazovce kontroly najednou zobrazit statistiky?
Aktuální snímek a dialog statistiky lze najednou zobrazit tak, že změníte průsvitnost dialogu statistiky. To lze provést pomocí panelu View (Zobrazení) nebo tlačítka [MENU] na konzole.
Kolik příkazů lze nastavit pomocí jedné příkazové jednotky?
Až 16. Nastavit lze pouze jeden vlastní příkaz (ale vlastní příkaz může obsahovat až 16 příkazů).
Lze nějak zjistit, když u příkazu nebo u příkazové jednotky dojde k chybě?
Lze to zjistit dvěma způsoby.
Obvykle je posuzovací hodnota příkazové jednotky uvedena ve výstupu jako celkový stav.
Hodnota [Wait Response] (Čekání na odpověď) přitom musí být nastavena jako podmínka, takže zpracování blokového diagramu může trvat déle.
Ve výstupu jsou uvedeny i chyby příkazu globálního nastavení >internal, které jsou uživatelem přiřazeny k %Error0/1. Když je zobrazen dialog, zobrazí se také chybová odpověď, která je užitečná pro statistiky. U sdílených chyb, jako je například odpojená kamera, to však znamená, že zařízení přestane pracovat z důvodu chyby příkazu. Proto je třeba přiřazení vždy pečlivě vybírat. (Ve výchozím nastavení žádná přiřazení nejsou.)
Co se stane se zbývajícími příkazy, dojde-li k chybě příkazu během zpracování více příkazů nastavených na příkazovou jednotku?
Dojde-li k chybě příkazové jednotky, žádné příkazy nebudou provedeny.
Zpracování bude pokračovat na další jednotku, ale příkaz bude proveden pouze částečně, takže pokud byly zapsány proměnné, mohou se ve výsledcích vyskytnout nekonzistence.
Co se stane, dojde-li na příkazové jednotce k chybě ve formátu u více příkazů?
Příkazová jednotka zahlásí chybu jednotky a příkaz nebude proveden.
V tomto případě není příkaz vydán, takže je vyloučena i chyba příkazu jako příčina chyby.
Tato chyba by měla být zjištěna při kontrole před nahráním.
Do které přímé paměti se zadávají znaky, které budou změněny, když PLC Link nebo CC-Link provede příkaz CW zápisu REG?
Příkaz je CW,nnnn(ID jednotky),m(číslo řádku),*01. Vyberte znaky, které mají být změněny na přímou paměť, která podporuje *01 (parametr příkazu), s hodnotou odpovídající tabulce kódování znaků jednotky OCR (viz kapitolu 6 Vestavěné pokyny v referenční příručce XG VisionEditor (verze pro programování)). Existuje-li více znaků, je toto zadáno dvěma slovy na znak z přímé paměti podporující *01. (Změnit lze až 20 znaků.)
Chcete-li například změnit 123 a REG, kde DM podporující *01 je 700, zadejte 49 pro DM700, 50 pro DM702, 51 pro DM704 a 0 pro DM706. (Jakmile uložení v přímé paměti dosáhne 0, čtení skončí.)
Lze v systému externě změnit nastavení data a času?
Toto nastavení lze změnit pomocí příkazu TW.
Když se pokouším změnit tvar oblasti, objeví se zpráva [Operations for variable referencing cancelation not allowed] (Operace pro zrušení odkazů na proměnné nejsou povoleny) a žádné změny nemohu provést.
Pokud v nastavení účtu nemáte práva na zrušení odkazů na proměnné, změny ve zrušení odkazů na proměnné (například změnu obdélníkové oblasti přiřazené k proměnné na oblouk) nemůžete provádět.
Když se pokusím smazat odlučovací filtr, objeví se zpráva [Changes to high speed mode not allowed] (Změny do vysokorychlostního režimu nejsou povoleny) a filtr se smazat nepodaří.
Odlučovací filtr lze smazat pouze tehdy, je-li vysokorychlostní režim nastaven na [Constant (fast)] (Konstantní (rychlý)).
Chcete-li odlučovací filtr deaktivovat v případě, že je vysokorychlostní režim nastaven jinak, změňte v parametrech počet odlučování na 0.
V dialogu úpravy jednotky jsem omylem zrušil přiřazení proměnné. Lze ji obnovit?
Něco takového v zásadě obnovit nelze.
Lze to však napravit, pokud před zavřením dialogového okna, ve kterém jste přiřazení proměnné zrušili, zvolíte možnost [Cancel] (Zrušit).
Když otevřu dialogové okno úpravy jednotky, objeví se zpráva [This dialog cannot be operated because there is an unrecoverable setting error in this unit] (S tímto dialogem nelze pracovat, protože v nastavení této jednotky se vyskytuje neopravitelná chyba) a jednotku nelze nastavit.
K tomu může dojít, pokud otevřete dialog úpravy jednotky pro jednotku, v jejímž nastavení se vyskytuje chyba.
Pokud je zde například přiřazena neplatná proměnná nebo data, změny nelze provést pomocí dialogu úpravy jednotky a objeví se tato zpráva. Výjimečně však můžete otevřít [Inspection Region] (Oblast kontroly), [Color] (Barva) a další [Unspecified errors] (Nespecifikované chyby), které lze nastavit pomocí dialogu úpravy jednotky.
Vylepšil jsem verzi řídicí jednotky na 2.1, v nabídce funkce se mi však neobjevuje tlačítko [Edit unit] (Upravit jednotku).
Formát globálního nastavení řídicí jednotky je podporován ve verzi 2.0 nebo dřívější.
Verzi programových souborů zjistíte kliknutím na [System Configuration] (Konfigurace systému) > [System Information] (Informace o systému).
Jaká nastavení jsou třeba k používání dialogů úpravy jednotky?
Verze souboru programu musí být 2.1 nebo novější.
Dialogy úpravy jednotky lze navíc použít, jsou-li povoleny možnosti [Expand controller adjustment functions] (Rozšířit funkce úpravy řídicí jednotky) a [Select units for editing] (Vybrat jednotky k úpravě). Měnit položky v dokončeném blokovém diagramu ani definovat nebo přiřazovat nové proměnné není třeba.
Které jednotky mají dialogy pro úpravy jednotky, které podporují změny nastavení?
Všechny měrné jednotky, záznamové jednotky a jednotky pro zpracování obrazu. Všechny ostatní jednotky změny nastavení nepodporují.
Mohu pomocí dialogu pro úpravu jednotky změnit pouze jednu určitou jednotku?
Ano.
Když v úvodním dialogu otevřete dialog úpravy jednotky, pomocí volby [Select units for editing] (Vybrat jednotky k úpravě) můžete vybrat některé z příslušných jednotek, které jsou aktuálně nastaveny v blokovém diagramu. Můžete také nastavit, aby určité jednotky bylo možné upravovat vždy.
Pokud dialog úpravy jednotky otevřete přímo příkazem, můžete také změnit příslušné jednotky, které nebyly vybrány pomocí [Select units for editing] (Vybrat jednotky k úpravě).
Jaká nastavení lze upravit pomocí dialogů úpravy jednotky?
Upravit lze většinu položek odpovídajících jednotek.
Informace o tom, zda položku lze nebo nelze upravit, je uvedena v seznamu dat nastavení v referenční příručce XG VisionEditor (verze pro programování).
Některé podporované položky musí být také nastaveny nebo mít přiřazeny proměnné v programu VisionEditor (například [Count] (Počet)).
Je třeba k nastavení, která budou změněna pomocí dialogu úpravy jednotky, přiřadit proměnné?
Ne, jako základní pravidlo to třeba není.
Výjimkou je výsledná obrazová proměnná, kterou musí program VisionEditor přiřadit k obrazové operaci, a proměnná skalárního pole ukládající koeficient filtru přiřazený k pokročilému vlastnímu filtru. Všechny ostatní položky lze změnit, aniž by bylo třeba přiřazovat proměnné.
Přestože hodnoty lze měnit, i když je přiřazena proměnná, vymažete-li přiřazení proměnné pomocí možnosti [Clear] (Vymazat), nebude je už možné obnovit. (Proměnná může být zrušena automaticky, například když je změněn tvar oblasti, zatímco proměnná je přiřazena k souřadnicím oblasti.)
Pokud je navíc přiřazena systémová proměnná, tuto položku změnit nelze.
Jaké množství programové paměti využívá možnost [Expand controller adjustment function] (Rozšířit funkci nastavení řídicí jednotky), když jsou použity dialogy pro úpravu jednotky?
To závisí na stavu nastavení blokového diagramu.
Obecně platí, že čím více jednotek a výsledných položek se zde vyskytuje, tím více paměti je potřeba. Kromě toho se obrazová paměť využívá při práci s obrazem.
Jaká nastavení jsou zapotřebí ke změně počtu [Count] objektů blob a dalších položek spojených s dialogy úpravy jednotek?
Pro objekty blob a další položky spojené s verzí 2.1 a pozdější bylo přidáno nastavení [Allow change in count value with controller] (Povolit změny hodnoty počtu pomocí řídicí jednotky). Zapnutím tohoto nastavení a jeho úpravou na [Maximum] bude možno řídicí jednotku použít ke změně počtu celé řady nastavení uvedených v rámci možnosti [Maximum].
Jak otevřu dialog úpravy jednotky pomocí tlačítka přímého otevření?
Stejně jako jiné dialogy lze i zvolený dialog úpravy jednotky (spouštěcí dialog, horní dialog, dílčí dialog) otevřít přímo zadáním ID dialogu pomocí příkazu. ID dialogu je zvýšeno na šest číslic, aby bylo možné používat konvenční příkazy DO i vyhrazené příkazy BU.
Jakou výhodu představuje [Regist. Img.] (Registr. obr.) jako zobrazení dialogu úpravy jednotky?
Stejně jako v řadě CV umožňuje použití registrovaného snímku zobrazit výsledek měření tak, aby bylo možné nejen nastavit více jednotek s registrovaným snímkem jako referencí, pokud je registrovaný snímek správně připraven, ale aby bylo možné dokončit i proces od nastavení po výsledek bez přípravy aktuálního snímku.
Co ve spouštěcím dialogu znamená funkce [Update Ref. Val.] (Aktualizace ref. hod.)?
Tato funkce upravuje referenční hodnotu všech jednotek úpravy pozice nastavených v blokovém diagramu s výsledky měření vypočítanými pomocí registrovaného snímku. (Ve výchozím nastavení je tato možnost vypnuta.)
Nastavení úpravy pozice je dokončeno, když je na obrazovce registrace změněno nastavení zdroje a cíle úpravy pozice a aktualizována referenční hodnota.
V závislosti na nastavení se však může stát, že referenční hodnota nebude aktualizována správně.
Lze v programu VisionEditor i v individuálních simulátorech používat dialogy úpravy jednotky?
Individuální simulátory mohou používat dialogy úpravy jednotky.
Nastavení lze upravit podobně jaké u simulátoru CV.
Po ukončení simulátoru je však třeba provést [Reload active inspection] (Znovu načíst aktivní kontrolu), aby změny v simulátoru nepřepsaly programový soubor v pracovním prostoru.
Během nastavení pomocí dialogu úpravy jednotky se často vypíná a zapíná výstup READY i další výstup a externí zařízení nefunguje správně.
V nastavení [Disable Function] (Deaktivovat funkci) u spouštěcí jednotky vyberte vypnutí vstupu i výstupu spouštěče, aby byl při otevírání dialogu úpravy jednotky příkaz [Ready] (Připraven) pevně nastaven na [Off] (Vypnuto) a [Data output] (Datový výstup) na [Off (Normal state)] (Vypnuto (Normální stav) a pod horním dialogem se mohl otevřít dialog úpravy jednotky.
Upozorňujeme, že řada XG nemá [Program mode] (Režim programu) a že nastavení dialogu úpravy jednotky obsahuje i [Run mode] (Režim spouštění).
Lze jednotku s nespecifikovanou chybou v části [Inspection Region] (Oblast kontroly) nebo [Color] (Barva) resetovat pomocí dialogu úpravy jednotky?
Ano.
Jednotky s chybami normálního nastavení nelze nastavit pomocí dialogů úpravy jednotky, možnost [Inspection Region] a [Color] však tímto způsobem upravit lze.
Protože však není podporováno nastavení přiřazení proměnných ani (v případě oblastí) přiřazení a změny nastavení pozice, nelze pomocí řídicí jednotky vždy provádět stejné změny nastavení jako v programu VisionEditor.
Kdy budou použity změny nastavení pomocí dialogů úprav jednotek?
Provedené (potvrzené) změny se projeví okamžitě.
Mohu zvolit, které dialogy úprav jednotek budou spustitelné?
Č.
Mohu pomocí dialogu pro úpravu jednotky přidávat, mazat a měnit pořadí předběžného zpracování?
Ano.
Nelze však přidávat vlastní dialogy.
Chcete-li změnit pořadí, použijte tlačítko č. 1 nebo 7 + nahoru/dolů.
Co se stane se změnami, když se ke změně parametrů v systému použije dialogové okno úprav jednotky a nastavení se pak nahrají do programu VisionEditor?
Změny budou v programu VisionEditor přepsány daty.
Je-li dialogové okno pro úpravu jednotky použito ke změně parametrů, k nimž nejsou přiřazeny proměnné, budou data nastavení upravena tak, aby byly přepsány změny. Měníte-li parametry pomocí přiřazení proměnných, můžete samozřejmě zvolit, zda u cíle nahrávání chcete nebo nechcete zachovat výchozí nastavení.
Změnil(a) jsem měřítko pomocí [Scale Factor] (Faktor měřítka), ale nepoužilo se na naměřenou hodnotu jednotky. Co se stalo?
V nabídce [Unit Properties] (Vlastnosti jednotky) zvolte [Tool Parameters] (Parametry nástroje) a u jednotky, na kterou chcete měřítko uplatnit, nastavte měřítko na [ON] (Zapnuto). Ve výchozím nastavení je tato volba nastavena na [OFF] (Vypnuto).
Nastavení jednotky je správné, ale nezobrazuje se graf okraje. Co se stalo?
Možnost [Regions] ve vlastnostech obrazovky na obrazovce kamery může být nastavena na [All] (Vše). V takovém případě se graf okraje nezobrazí. Graf okraje se zobrazí, pouze je-li tato volba nastavena na [Single] (Jednotlivě).
Nechtěně jsem smazal jednotku. Lze ji obnovit?
Pomocí funkce [Undo] (Vrátit zpět) můžete ve zobrazení blokového diagramu vrátit zpět poslední dva provedené úkony, v editoru obrazovky posledních osm úkonů. Úkon vrátíte klávesovou zkratkou [Ctrl+z].
Dojde-li k chybě v matematickém výrazu, následující řádky nejsou provedeny.
To je správně. Dojde-li k chybě v matematickém výrazu, následující výpočty nejsou provedeny. Nejsou-li numerické hodnoty výpočtu správně uloženy, zkontrolujte, zda nedošlo k chybě jednotky.
Pomocí pokročilého vlastního filtru nemohu nastavit koeficient filtru.
Skalární proměnná pole pro ukládání koeficientu filtru musí být definována jako uživatelská proměnná. Skalární proměnnou pole definujte podle velikosti filtru.
Například pro filtr o velikosti 21×21 definujte skalární proměnnou pole se 441 nebo více prvky.
Čekající jednotka v individuálním simulátoru nefunguje správně.
Čekající jednotky (kromě jednotek uživatelské nabídky) v individuálním simulátoru nefungují. Další informace naleznete v kapitole 7 v části Přehled funkcí simulací referenční příručky XG VisionEditor.
Zkusil jsem k nastavení vytvořenému ve verzi 1.0 přidat funkce verze 2.0, ale došlo k chybě.
Funkce nelze přidávat, dokud není samotné nastavení zkonvertováno do formátu verze 2.0. Chcete-li nastavení uložit ve formátu verze 2.0, v programu VisionEditor vyberte možnost [File] (Soubor) a [Save in another file format] (Uložit v jiném formátu souboru). Je důležité vědět, že i globální nastavení má verzi.
Nahrál jsem data globálního nastavení, ale nemohu je aktualizovat.
Restartujte řídicí jednotku. Na rozdíl od dat programu se data globálního nastavení aktualizují až po restartování řídicí jednotky.
V programu VisionEditor verze 2.0 lze data globálního nastavení aktualizovat restartováním řídicí jednotky z programu VisionEditor, aniž by bylo třeba zapnout a vypnout systém.
Pomocí řídicí jednotky jsem nastavil(a) rychlost závěrky a další nastavení kamery, ale na kameře se tyto změny vůbec neprojevily.
Ve výchozím nastavení lze nastavení kamery upravit pouze pomocí záznamové jednotky programu XG VisionEditor. Změny nastavení kamery na řídicí jednotce se neprojeví. Chcete-li změnit nastavení kamery na řídicí jednotce, vyberte na kartě [Capture Opt.] (Možnosti záznamu) příslušné záznamové jednotky možnost [Use system settings] (Použít nastavení systému).
Pokud je jako spouštěč použit vstup z konzole, záznam neproběhne.
Důvodem může být, že když záznamová jednotka není pod spouštěcí jednotkou, nad záznamovou jednotkou je čekající provedení (jako čekající provedení terminálu) a jednotka není provedena. Chcete-li získat bližší informace, kontaktujte místního obchodního zástupce.
Došlo ke vstupu spouštěče, ale obrazová data na monitoru nebyla aktualizována.
Obrazová data se aktualizují, jakmile blokový diagram dosáhne koncové jednotky. Proces se možná zastavil na některém bodě uprostřed blokového diagramu. Zkontrolujte, zda je volba %WaitReady nastavena na ON (Zapnuto), a uvidíte, jestli je blokový diagram ve stavu čekání. Chcete-li získat bližší informace, kontaktujte místního obchodního zástupce.
Ke změně hodnot byl použit dialog simulátoru, ale hodnoty nebyly použity na nastavení. Jak tyto změny použiji pomocí simulátoru?
Pro proměnné, které mají měnit hodnoty v systému, předem vyberte [Copy current value to initial value at save] (Při uložení zkopírovat aktuální hodnotu na hodnotu počáteční). Poté, co pomocí simulátoru změníte hodnoty, nastavení v simulátoru uložte. (Použijte možnost [Save settings] (Uložit nastavení) v nabídce funkce.) Poté v nabídce [File] (Soubor) vyberte pro stejná nastavení možnost [Reload active inspection] (Znovu načíst aktivní kontrolu).
Poté, co jsem hodnoty upravil(a) a uložil(a) do systému XG a aktuální hodnoty proměnných zkopíroval(a) na hodnoty počáteční, jsem blokový diagram změnil(a) v programu VisionEditor a nahrál(a) jej do systému XG. Počáteční hodnoty proměnných, které jsem v systému upravil(a), však byly resetovány. Co se stalo?
Počáteční hodnoty proměnných byly přepsány nahranými daty.
Pro proměnné, které mají měnit hodnoty v systému, předem vyberte [Copy current value to initial value at save] (Při uložení zkopírovat aktuální hodnotu na hodnotu počáteční).
Poté, co hodnoty v systému změníte, uložte je (aktuální hodnoty zkopírujte na hodnoty počáteční) a s tímto nastavením je stáhněte (načtěte počáteční hodnoty) do programu VisionEditor.
Blokový diagram na straně programu VisionEditor změňte na stažená nastavení.
Pokud je v programu VisionEditor verze 2.0 a novější v nastavení proměnné vybrána možnost [Keep initial value when loading program] (Při načítání programu zachovat počáteční hodnotu) a při nahrávání je vybrána možnost [Target Data] (Cílová data), nastavení lze nahrát, aniž by byly počáteční hodnoty proměnných v systému XG změněny. V možnostech nastavení kontroly je třeba pro [Initial Values of Variables] (Počáteční hodnoty proměnných) vybrat [Use settings] (Použít nastavení) a provést nahrání.
Přestože v syntaxi výpočtu není žádná chyba, při výstupu nevydá výsledek. Jak zkontroluji výstup?
Mohlo dojít k dynamické chybě. Zkontrolujte protokol provádění.
Nemohu potvrdit příčinu dynamické chyby, která je zobrazena v protokolu provádění.
U výpočetní jednotky, u níž došlo k chybě, zkontrolujte [Error code] (Kód chyby) a [Error line] (Řádek s chybou) v části [Unit Result] (Výsledek jednotky). Popisy chybových kódů naleznete v uživatelské příručce.
Nemohu zobrazit archiv, i když otevřu prohlížeč archivu snímků.
Chcete-li používat prohlížeč archivu snímků, musíte tuto možnost nastavit v programu XG VisionEditor. Chcete-li nastavit podmínky, vyberte [Settings] (Nastavení), [Image Archive] (Archiv snímků) a pro podmínky 0 až 7 vyberte možnost [Enable] (Povolit).
K počáteční hodnotě OUT23 je přiřazena proměnná %JAHold, OUT23 však funguje jinak než výstup OR řady CV.
Je-li systémová proměnná %JAHold posuzována jako NG, výstup pokračuje, dokud není systémová proměnná resetována. Systémová proměnná, která funguje stejně jako v řadě CV, je %JgAll. Proto ke globálnímu nastavení a terminálovému výstupu přiřaďte proměnnou %JgAll. Chcete-li získat bližší informace, kontaktujte místního obchodního zástupce.
Vytvořil(a) jsem dialog a změnil hodnotu proměnné přiřazené k numerickému vstupnímu poli, změna se však neprojevila.
V nastavení dialogu programu XG VisionEditor zkontrolujte nastavení časování aplikace.
Pokud je například časování potvrzení nastaveno na [when button is pressed] (když je stisknuto tlačítko), nastavení není potvrzeno, dokud není stisknuto dialogové nebo spodní tlačítko. Chcete-li získat bližší informace, kontaktujte místního obchodního zástupce.
Prohlížeč archivu snímků v systému za provozu zobrazuje černý snímek, ale žádné archivované snímky.
Archivované snímky byly přepsány novými a vymazány.
Chcete-li zobrazit nové snímky, klikněte na [Update] (Aktualizovat).
Na monitoru vstupu/výstupu je vždy úspěšně zadán spouštěč, ale v několika případech se zdá, že zadání spouštěče je vloženo pouze jednou.
Aktualizace zobrazení monitoru vstupu/výstupu se nedokážou přizpůsobit rychlosti spouštěče. Chcete-li zkontrolovat, zda byl signál správně vypnut a zapnut, použijte prohlížeč protokolu trasování.
Chci vložit spouštěč pomocí [Wait terminal I/O] (Počkat na vstup/výstup terminálu), ale stisknutím tlačítka [TRIGGER] (Spouštěč) na konzoli spouštěč nelze vložit.
Používáte-li možnost [Wait terminal I/O] (Počkat na vstup/výstup terminálu), vstup spouštěče lze získat pouze z terminálu.
Ke vložení spouštěče z konzole můžete použít proměnnou zpožďovací jednotky jako obvykle, ale nemůžete použít současně [Wait terminal I/O] (Počkat na vstup/výstup terminálu) a [Variable delay] (Proměnná zpoždění).
V programu VisionEditor verze 2.0 a pozdější přibyl příkaz WG (Waiting status release) (Čekání na vydání stavu) a příkaz [Wait terminal I/O] (Počkat na vstup/výstup terminálu) lze zrušit vydáním příkazu z konzole.
Musím vytvářet dialog, když chci v systému změnit rychlost závěrky kamery?
Při vytváření blokového diagramu vyberte u záznamové jednotky na kartě [Capture Opt.] (Možnosti záznamu) možnost [Use system settings] (Použít nastavení systému).
Tímto způsobem se změny vytvořené v nastavení kamery [Camera Settings] (Nastavení kamery) nabídky konfigurace systému [System Configuration] (Konfigurace systému) aplikují na kontrolu.
Po restartu systému se program vrátí na [0000]. Mohu ale určit číslo, na kterém se má program spustit?
Tuto možnost můžete změnit v nabídce [Global] (Globální), [System Settings] (Nastavení systému), možnost [Program to start up] (Začátek programu).
Chci-li vymazat program, musím smazat veškerá nastavení editoru a program nahrát?
Veškerá nastavení můžete vymazat pomocí inicializace systému. Systém inicializujete, když při zapínání přístroje stiskněte a přidržte klávesu [Esc].
Dialog nelze zavřít stisknutím klávesy [Esc].
Může se jednat o úvodní dialog. Ve vlastnostech dialogu odstraňte značku zaškrtnutí u nastavení úvodního zobrazení. Jinak nemusí být vybrána možnost [Close dialog on Escape] (Zavřít dialog klávesou Escape).
Osvětlení je řízeno příkazovou jednotkou, ale vzdálené snímání nelze správně provést.
Vzdálené snímání probíhá pouze prostřednictvím záznamové jednotky, takže příkazové jednotky k tomu řídicí jednotka nepoužije. Tento problém lze vyřešit tak, že cílový snímek uložíte pomocí prohlížeče Image Archive.
V protokolu trasování se nezobrazují výstupní signály odlesků.
Výstup odlesků nelze v protokolu trasování zobrazit. Protože jsou však v seznamu položek protokolu trasování zobrazeny položky, které jsou v globálním nastavení přiřazeny k nastavení terminálu, nezobrazují se tvary vln a výstupem jsou pouze položky odlesků.
Jsou v protokolu změn zaznamenány všechny systémové úkony?
Data zaznamenávaná v protokolu změn se týkají výhradně úkonů, které lze provádět pomocí systému XG. Existuje mnoho úkonů, které zaznamenány nejsou. Bližší informace naleznete v kapitole 5 referenční příručky XG VisionEditor (verze pro programování). Úkony, které zde nejsou uvedeny, se nezaznamenávají.
Na PLC nelze potvrdit signál a nelze navázat komunikaci.
Pomocí prohlížeče protokolu trasování zkontrolujte, zda systém XG vydává signál. Přiřazení terminálů zjistíte pomocí nabídky [Global] (Globální).
%Trg1Ready nelze spustit, čeká-li s [Wait terminal I/O] (Počkat na vstup/výstup terminálu).
Signál Ready, který se při čekání spouští  [Wait terminal I/O], je %WaitReady. Zkontrolujte tento signál.
Proč nefunguje %Flash3 a %Flash4, když používám jednotku regulátoru osvětlení CA-DC20E? Rozsvítí se, když je možnost [Continuous] (Průběžně) nastavena na ON (Zapnuto).
%Flash3 a %Flash4 nejsou v globálním nastavení přiřazeny k výstupním terminálům pro vstup/výstup. Jednotka regulátoru osvětlení CA-DC20E nevyžaduje připojení %Flash, ale stav %Flash je odkazován interně, takže bez přiřazení terminálu nebude fungovat.
Uložil(a) jsem pracovní prostor na kartu SD, která byla vložena do pozice 2 pro kartu SD, ale pomocí řídicí jednotky nemohu načíst nastavení. V čem je problém?
Data nastavení pracovního prostoru jsou uložena, takže samotný pracovní prostor se do řídicí jednotky neodesílá. Různá data (nastavení, globální data apod.) lze zkopírovat do příslušných hierarchií a umožnit tak přenos dat pomocí karty SD.
Po zadání příkazu RE pro vstup/výstup terminálu ve stavu čekání dojde k chybě a příkaz není proveden.
Příkaz RE funguje pouze pro spouštěč čekání, čekání na vstup/výstup terminálu nebo proměnnou zpoždění pro záznamovou jednotku. Verze 1.0.0011 a starší však čekání na vstup/výstup terminálu ani proměnnou zpoždění nepodporují. Také mějte na paměti, že uživatelskou nabídku nelze zrušit.
Odkazy na proměnné slouží k přečíslování registrovaného snímku. Změna proměnné však registrovaný snímek nezmění.
Pouhou změnou proměnné nelze registrovaný snímek změnit. Registrovaný snímek se změní, je-li po změně proměnné vydán příkaz NU.
Když aktivuji proměnnou %OutDataAsyncA to H, nemohu ji již vypnout.
%OutDataAsyncA to H může asynchronně ovládat blokový diagram. Pokud je však aktivována, už ji nelze zrušit. Musíte ji zrušit ručně pomocí příkazu.
Jak přenesu statistická data z jedné karty SD do počítače, aniž by bylo třeba kartu SD odstraňovat?
Ke stažení souborů uložených na kartě SD můžete použít program VisionEditor nebo VisionTerminal. V systémovém zobrazení programu VisionEditor vyberte v seznamu [Controller List] (Seznam řídicích jednotek) soubory, které chcete přenést, a poté přenos dat zahajte kliknutím pravým tlačítkem a výběrem možnosti [Download] (Stáhnout).

Zpět nahoru

KEYENCE INTERNATIONAL (BELGIUM) NV/SA Sídlo společnosti:
Bedrijvenlaan 5, 2800 Mechelen, Belgie
Tel (Česká republika): +420 220 184 700
Tel (Slovensko): +421 (0) 2 5939 6461
E-mail: info@keyence.eu
Nabídka zaměstnání: Kariérní portál KEYENCE